bassist22
Posts: 2
Joined: Sun Nov 01, 2015 7:02 pm

/etc/bluetooth/audio.conf MISSING

Sun Nov 01, 2015 7:21 pm

So I've been following this tutorial to set up bluetooth audio streaming on my Pi 2 Model B:
viewtopic.php?t=68779

I've got 2015-09-24-raspbian-jessie as my operating system.

I install what it tells me using: sudo apt-get install bluez pulseaudio-module-bluetooth python-gobject python-gobject-2

From there it tells me to edit /etc/bluetooth/audio.conf

This just doesn't exist.

I've formatted the card and reinstalled the operating system, and still nothing.
I've tried installing every bluetooth-related thing I can find, and none of them help.
I've purged all those packages and reinstalled to no success.
I'm at a loss after spending days trying to fix this and nothing helps...
I just don't understand where I'm going wrong so any help at all setting this up would be greatly appreciated.

steveb1475
Posts: 3
Joined: Thu Jun 11, 2015 4:19 am

Re: /etc/bluetooth/audio.conf MISSING

Mon Nov 30, 2015 3:49 am

Did you ever solve this? I'm in the same situation, trying to follow that tutorial and my audio.conf is missing as well.

bassist22
Posts: 2
Joined: Sun Nov 01, 2015 7:02 pm

Re: /etc/bluetooth/audio.conf MISSING

Tue Dec 15, 2015 7:44 pm

steveb1475 wrote:Did you ever solve this? I'm in the same situation, trying to follow that tutorial and my audio.conf is missing as well.
Nope, I never got it figured out. Wish I had though!

User avatar
Douglas6
Posts: 5144
Joined: Sat Mar 16, 2013 5:34 am
Location: Chicago, USA

Re: /etc/bluetooth/audio.conf MISSING

Tue Dec 15, 2015 8:19 pm

That 'tutorial' is almost 2 years old now, and Raspian and BlueZ have moved on. One change in BlueZ is that various configuration files were consolidated onto one: main.conf. You could try the recommended changes in that file, but I'm not sure what other changes to that tutorial might be needed. I haven't tried Bluetooth streaming under the Jessie Raspian just yet.

kitramos
Posts: 3
Joined: Sat May 26, 2012 5:27 pm

Re: /etc/bluetooth/audio.conf MISSING

Sun Apr 10, 2016 4:58 am

Well I made a bit of progress in this

I stuck that line it wanted in that fine in the

Code: Select all

/etc/bluetooth/main.conf
then rebooted, and then checked

Code: Select all

bluetoothctl
it showed my headset paired but not connected, so I issued the connect command it connected fine.

then I tried

Code: Select all

pactl list sources short
and how it does show a

Code: Select all

0       alsa_output.0.analog-stereo.monitor     module-alsa-card.c      s16le 2ch 44100Hz       SUSPENDED
1       bluez_sink.00_25_DB_43_24_1B.monitor    module-bluez5-device.c  s16le 2ch 44100Hz       SUSPENDED
so I believe i got the pi recognizing that it can send audio to my bluetooth speakers, but not sure how to tell it I want it to send the audio there instead.

User avatar
Douglas6
Posts: 5144
Joined: Sat Mar 16, 2013 5:34 am
Location: Chicago, USA

Re: /etc/bluetooth/audio.conf MISSING

Tue Apr 12, 2016 4:51 pm

It seems to me, if a Bluetooth speaker is connected, PulseAudio will automatically route audio to it.

[EDIT: Oh, and the 'Enable=Source,Sink,Media,Socket' line is no longer required.]

fungus666
Posts: 4
Joined: Sat Jun 18, 2016 4:25 am

Re: /etc/bluetooth/audio.conf MISSING

Sat Aug 20, 2016 11:19 pm

Try Changing the device class to Class 0x20041C (Audio/Audio/Portable Audio)
or find a better tutorial.

Arie Aardvarken
Posts: 4
Joined: Thu Sep 01, 2016 7:32 pm

Re: /etc/bluetooth/audio.conf MISSING

Thu Sep 01, 2016 7:51 pm

I have exactly the same issue as kitramos posted on Sun Apr 10, 2016 5:58 am, on the raspberry pi 3 (NOOBS + rasbian) with its build in bluetooth and an headset from philips: SHB8850NC.
It shows when I run the command

Code: Select all

pactl list sources short

--> OUTPUT:
0       alsa_output.0.analog-stereo.monitor     module-alsa-card.c      s16le 2ch 44100Hz       SUSPENDED
2       bluez_sink.6C_5A_B5_FC_4A_17.monitor    module-bluez5-device.c  s16le 2ch 44100Hz       SUSPENDED
just as with kitramos, but then I need this device to be my audio, which I believe can be done by settings that relate to audio sink or something similar. I have tried many things, including many that had to do with audio sinks. The latest I tried was:

Code: Select all

pacmd set-card-profile 2 a2dp_sink
But my ouput here was:

Code: Select all

No such profile: a2dp_sink
I removed the "_sink", and it didn't gave any respond, also no errors, but it also did not work. Autorouting is also not happening. I tried a lot of tutorials and I would be very happy to get this finally working after many hours. I find it strange that it is so complicating from the command line, while it can be easily done from the rasbian desktop.

If anyone could help me/us out that would be great! Or suggestions for a good updated tutorial, lots of them are quite outdated.

Thanks in advance

Return to “Troubleshooting”