adwen
Posts: 10
Joined: Sun Jul 08, 2012 5:51 pm

jessie[-lite] NFS mount fstab not working after reboot.

Sat Dec 12, 2015 7:32 pm

I have just made a fresh install of Raspbian (Jessie-lite version) on my raspberry pi model B+. I have noticed that some stuff changed but I'm having some problems with my NFS mounts. I have been using the following way described on the Raspbian FAQ website: https://www.raspbian.org/RaspbianFAQ#Ho ... S_share.3F:
How do I mount directories from other Linux/Unix/BSD servers? How do I mount an NFS share?
First, you need a server that can use the Network File System (NFS). Let's assume you have a server named adelaide at 192.168.222.34 and it has a share called public that you want to mount at /public on your Pi.

First, install the necessary packages. I use aptitude, but you can use apt-get instead if you prefer; just put apt-get where you see aptitude:

sudo aptitude install nfs-common portmap

(nfs-common may already be installed, but this will ensure that it installs if it isn't already)

On the current version of Raspbian, rpcbind (part of the portmap package) does not start by default. This is presumably done to control memory consumption on our small systems. However, it isn't very big and we need it to make an NFS mount. To enable it manually, so we can mount our directory immediately:

sudo service rpcbind start

To make rpcbind start automatically at boot:

sudo update-rc.d rpcbind enable

Now, let's mount our share:

Make a directory for your mount. I want mine at /public, so:

mkdir /public

Mount manually to test (remember, my server is adelaide at 192.168.222.34 and the share is public):

mount -t nfs 192.168.222.34:/public /public

(my server share path) (where I want it mounted locally)

Now, to make it permanent, you need to edit /etc/fstab to make the directory mount at boot. I added a line to the end of /etc/fstab:

192.168.222.34:/public /public nfs rsize=8192,wsize=8192,timeo=14,intr 0 0

The rsize and wsize entries are not strictly necessary but I find they give me some extra speed.
There are ways you can refer to your server by name instead of by its IP address like we did above. Have a look at /etc/hosts for a starting point. The rest is left as an exercise for the reader.
This doesn't work any more in jessie.

So my question what is the right way to make this work? I did a dirty hack right now (without fstab) for the moment but I'm still curious on what is the right way.

AND please raspbian team update your FAQ.

timrowledge
Posts: 1408
Joined: Mon Oct 29, 2012 8:12 pm
Location: Vancouver Island

Re: jessie[-lite] NFS mount fstab not working after reboot.

Sun Dec 13, 2015 7:00 pm

I'm using

Code: Select all

192.168.1.65:/Users/tim /home/pi/DizietFS nfs rsize=8192,wsize=8192,timeo=14,intr,noauto,x-systemd.automount 0 0
which as you will quickly notice is the same basic command with the 'noauto,x-systemd...' stuff added. I found it with a lot of googling some time ago but can't recall even faintly where.
Making Smalltalk on ARM since 1986; making your Scratch better since 2012

ernesto.barroso
Posts: 1
Joined: Mon Dec 14, 2015 7:11 pm

Re: jessie[-lite] NFS mount fstab not working after reboot.

Mon Dec 14, 2015 7:20 pm

noauto,x-systemd.automount
it didn't work for me. finally i've installed rpcbind 0.2.3-0.2 from testing (/etc/apt/sources.list):

Code: Select all

deb http://ftp.es.debian.org/debian testing main
with

Code: Select all

sudo apt-get install rpcbind=0.2.3-0.2
in order to get rpcbind started on boot.

Return to “Raspberry Pi OS”