Bosse_B
Posts: 1318
Joined: Thu Jan 30, 2014 9:53 am

I need libxslt but apt-get cannot find it

Tue Mar 08, 2016 10:21 am

I need to install a number of packages for building man pages for gpsd on a Jessie system.
According to the instructions (gpsd 3.16 build.txt) I need the following packages:
libxslt
docbook-xsl
xmlto
asciidoc
So I created a call as follows and received the response I did not want:

Code: Select all

pi@rpi3-jessie:~ $ sudo apt-get install libxslt docbook-xsl xmlto asciidoc
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package libxslt
Any ideas as to what I need to do in order to get these packages?
I tried googling but nothing obvious popped up.
Bo Berglund
Sweden

User avatar
RaTTuS
Posts: 10828
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK

Re: I need libxslt but apt-get cannot find it

Tue Mar 08, 2016 10:23 am

How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

fruitoftheloom
Posts: 27225
Joined: Tue Mar 25, 2014 12:40 pm

Re: I need libxslt but apt-get cannot find it

Tue Mar 08, 2016 10:24 am

Bosse_B wrote:I need to install a number of packages for building man pages for gpsd on a Jessie system.
According to the instructions (gpsd 3.16 build.txt) I need the following packages:
libxslt
docbook-xsl
xmlto
asciidoc
So I created a call as follows and received the response I did not want:

Code: Select all

pi@rpi3-jessie:~ $ sudo apt-get install libxslt docbook-xsl xmlto asciidoc
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package libxslt
Any ideas as to what I need to do in order to get these packages?
I tried googling but nothing obvious popped up.

Code: Select all

sudo apt-get update
sudo apt-get dist-upgrade
sudo reboot
Then try again, but always apt-get update first to sync the repositories
Take what I advise as advice not the utopian holy grail, and it is gratis !!

Bosse_B
Posts: 1318
Joined: Thu Jan 30, 2014 9:53 am

Re: I need libxslt but apt-get cannot find it

Tue Mar 08, 2016 2:10 pm

The update, dist-update did nothing...

But using the RaTTuS link I found that I could use this:
libxlt1-dev
After I installed that it worked fine.
Bo Berglund
Sweden

Return to “Raspberry Pi OS”