Posts: 519
Joined: Fri Feb 13, 2015 3:18 pm

Anyone used a Tecknet iEP390 9000mAh as UPS?

Fri Apr 15, 2016 2:38 pm

As the title.
I have a Pi model B. Wifi dongle. Nothing else connected.
Pack is fully charged.
Pi starts to boot then just shuts down after approximately 30s. No LED's lit.
Even if I disconnect the pack from the mains so it's not charging I get the same problem.
I have tried many different USB cables from device to Pi and device to mains 2.5A PSU.
It's not the Pi. It works fine from the same 2.5A PSU

I can only assume my Tecknet pack is faulty or not suitable for the Pi.
I know they have some inbuilt algorithms to detect discharge rate which could cause issue I guess, but do they also look for some 'magic' comms on the USB.

User avatar
Posts: 13217
Joined: Mon Sep 01, 2014 4:03 pm
Location: UK

Re: Anyone used a Tecknet iEP390 9000mAh as UPS?

Fri Apr 15, 2016 2:59 pm


Smart Charing
For Smart Devices
Get the most out of your smart devices With TeckNet's BLUETEK Technology, each Smart USB Port independently scans your smart device (phone, tablet etc) as it's plugged in and then configures itself to match the device's specific charging profile.

Fast Charging

TeckNet BLUETEK optimises the charge capacity for each Smart USB Port and ensures that your device recharges at the maximum speed (up to 2.4A) - up to 14% faster than traditional 2.1A USB chargers. As a result, your device will be charged efficiently and at the maximum speed possible

Ultimate Compatibility

TeckNet BLUETEK Technology automatically adjusts the output level to any device it’s connected to. This means you can easily and efficiently charge smartphones and tablets from Apple, Samsung, HTC, Google and BlackBerry, as well as a variety of digital cameras and handheld gaming devices
S0, just taking a guess... Maybe after about 30 secs it realises the power demand is kicking in and takes time out to 'optimise' itself. If it is being used as a charger there would be no visible impact of dropping its output for a while as it adjusts. But if it is being used as a power supply that would be fatal. As I say, nothing more than a guess. But it would explain the behaviour you are seeing. You would need some sort of monitoring like an oscilloscope be be sure. Or you could try asking the vendor if this is the way the Bluetek technology is expected to work.

[But to be clear: I have never used one of these devices myself so all the above is theoretical... ]

Posts: 1
Joined: Fri Apr 15, 2016 6:46 pm

Re: Anyone used a Tecknet iEP390 9000mAh as UPS?

Fri Apr 15, 2016 7:24 pm

I suspect your are not drawing enough current from the USB battery pack to keep it supplying power so it is shutting down.

Just tried a TeckNet iEP390 9000mAh on my Raspberry Pi Model A+, with the same result, the iEP390 stops supplying power after around 40 seconds, also tried it with a Raspberry Pi 2 Model B and it worked fine, worked for around 10 minutes before I unplugged it.

Connecting a USB power meter between the TeckNet iEP390 and Raspberry Pi I get the following results ..

Pi Model A+: mostly between 0.07 amps and 0.11 amps.
Pi 2 Model B: mostly between 0.19 amps and 0.24 amps, peaks at 0.34 amps during boot then drops down to 0.19 amps, with occasional slight increases upto 0.24 amps during the 10 minutes or so that I was watching.

Tests were done with nothing connected to the Raspberry Pi Model A+ / 2 Model B - just a micro SD card to boot from and the power connection.

Can't find a mention on the TechNet web site or the online documentation for the iEP390, but have noticed previously that with this USB battery pack and other similar ones that they will shutdown the output when the current drain drops to around 0.1 amps or possibly slightly more.

Try plugging some other device ( mobile phone ) into the 2nd USB power output from the iEP390 and see if that allows your Pi Model B to boot and the iEP390 to continuing supplying power.

Posts: 519
Joined: Fri Feb 13, 2015 3:18 pm

Re: Anyone used a Tecknet iEP390 9000mAh as UPS?

Sat Apr 16, 2016 4:38 pm

Ok. Cheers both.
I think my pack must be faulty.
I've plugged in my Sony Z3 phone to the 2A output and the Pi into the 1A and still it shuts down.
It won't even charge my Z3, it starts to, then a minute or so later, cuts power to the phone but leaves all its blue led's lit.
No worries.
I will invest in a proper UPS. With amount of power cuts we get here, it will be useful for other things too...

Return to “General discussion”