Ihf
Posts: 5
Joined: Sun Feb 04, 2018 2:46 am

Re: [VNC] Cannot currently show the dekstop

Thu Oct 24, 2019 11:34 pm

I am having the same problem. (Cannot currently show the desktop). This started after I upgraded Raspbian to Buster. I can ssh and use raspi-config to change the resolution but the problem persists. Can someone please help me to figure out what is wrong and to fix it. In retrospect, I should have created a new SD card with Buster and moved files over but now I have a headless system that I cannot use as the apps I need require the desktop.

Anyone?

Thank you.

pmpmtj
Posts: 1
Joined: Thu Nov 07, 2019 12:04 pm

Re: [VNC] Cannot currently show the dekstop

Thu Nov 07, 2019 1:03 pm

I had the same problem when I change to the Rapsberry Pi 4. Battled for hours :shock: but thanks to the online community I managed and therefore here is my contribution. I used the 2019-09-26-raspbian-buster-lite version and it works. Here are the steps I took after a fresh installation of the image and ssh using putty:
sudo apt-get update
sudo apt-get upgrade
reboot
sudo apt-get install raspberrypi-ui-mods
reboot
sudo raspi-config
Choose option (3) "Boot to desktop"
Set resolution (7) set to max 1920 x 1080 16:9
Activate VPN (5) in the case of the lite version the package will be downloaded and installed
exit and reboot
Open the VPN viewer - log in
Thats how it worked for me. Good Luck.
Cheers

ensemble2019
Posts: 1
Joined: Mon Nov 11, 2019 5:52 pm

Re: [VNC] Cannot currently show the dekstop

Mon Nov 11, 2019 5:59 pm

Raspberry 4B.
After HDMI disconnected and rebooted i cannot see the VNC desktop. This stupid raspbian bug has to be fixed.
You could let it run with some default resolution (vga, hd, full-hd).

When i go to Set resolution (a7) - I only see 1 possible option:
Default Monitor preferred resolution.
And there is NO way to choose anything else!!!!
This is another raspbian bug! It has to be fixed even faster.

Where can i put the resolution?

Frankenpi
Posts: 1
Joined: Fri Nov 22, 2019 10:14 pm

Re: [VNC] Cannot currently show the dekstop

Fri Nov 22, 2019 10:44 pm

I have a problem when I can't vnc-connect to the raspberry pi after unplugging the HDMI-cable. It works fine with VNC Viewer (from a MacBook) and VNC Server (on my raspberry pi 4) when HDMI-cable is connected.

I got it to work again after this steps:
ssh into the pi
sudo raspi-config
- choosing 7 Advanced options
- choosing A5 Resolution
- choosing Default 720x480
- rebooting
- trying to VNC
- failed with the same error message
- repeating the ssh
- going into raspi-config
- changing resolution to
- DMT Mode 82 1920x1080 60Hz 16:9
- rebooting, connecting with vnc

Then it worked again. Welcome to Linux, everything must be tinkered with I suppose.

Topsk
Posts: 1
Joined: Wed Dec 04, 2019 10:32 am

Re: [VNC] Cannot currently show the dekstop

Wed Dec 04, 2019 10:36 am

I had the same problem on the raspberry pi 4. But I followed this video and got the image on the VNC back https://m.youtube.com/watch?v=kPeb5IvZW_k&t=312s
Mainly, SSH into pi
sudo raspi-config
Go into interfaces and enable VNC then reboot

r3b3rb3r3
Posts: 1
Joined: Wed Jun 26, 2019 9:14 pm

Re: [VNC] Cannot currently show the dekstop

Mon Dec 16, 2019 7:49 pm

Frankenpi solved this for me. Look at his second attempt where he changes resolution. Thanks.

zouhair ben
Posts: 1
Joined: Sun Dec 22, 2019 10:30 pm

Re: [VNC] Cannot currently show the dekstop

Sun Dec 22, 2019 10:39 pm

wget http://www.spotpear.com/download/diver2 ... 115.tar.gz
tar xvf LCD-show.tar.gz
cd LCD-show/
sudo ./LCD101-1024x600-show



its calibration for lcd but it work with vnc

RobLatour
Posts: 38
Joined: Sat Dec 12, 2015 9:36 pm

Re: [VNC] Cannot currently show the dekstop

Fri Dec 27, 2019 3:18 am

+1 for Frankenpi. Thanks Frankenpi ! :D

rossyr125
Posts: 1
Joined: Sun Jan 05, 2020 5:30 pm

Re: [VNC] Cannot currently show the dekstop

Sun Jan 05, 2020 5:45 pm

Hi new to this site. I have been trying to wrap my head around this problem for some time the best fix for me was to connect a micro hdmi to hdmi female https://www.amazon.co.uk/dp/B00B2HORKE? ... b_ap_share and then plug my HDMI dummy plug,Headless Ghost, adapter https://www.amazon.co.uk/dp/B072PV6K8J? ... b_ap_share

Hope this helps

everydaylinuxuser
Posts: 1
Joined: Sat Jan 18, 2020 10:03 pm

Re: [VNC] Cannot currently show the dekstop

Sat Jan 18, 2020 10:07 pm

You can get around this issue in the following way:

When connecting to your raspberry pi specify the port number ie 192.168.1.1:5901

This worked for me.

In most cases the port number will be 5901 as this is the default.

caozuba
Posts: 1
Joined: Fri Feb 07, 2020 1:34 am

Re: [VNC] Cannot currently show the dekstop

Fri Feb 07, 2020 1:37 am

It is because you don't have an actual screen.
If you run raspberry pi headless (without a real monitor), you need to create a virtual screen by command: vncserver
then you will get an address of that virtual screen. Use that IP address for vncViewer
Reference here:
https://www.raspberrypi.org/documentati ... /README.md

Aishwarya Kabadi
Posts: 1
Joined: Wed Sep 25, 2019 8:30 am

Re: [VNC] Cannot currently show the dekstop

Tue Feb 25, 2020 6:35 am

https://www.youtube.com/watch?v=nQQFqSOgMSE&t=4s

check out this link and find the solution for cannot currently show desktop error

shakya89.das
Posts: 3
Joined: Tue Mar 17, 2020 9:54 pm

Re: [VNC] Cannot currently show the dekstop

Tue Mar 17, 2020 10:00 pm

Even XRDP (Remote Desktop) giving the same error :

pi@raspberrypi:~ $
pi@raspberrypi:~ $ sudo apt-get install xrdp
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
libglu1-mesa x11-apps x11-session-utils xbitmaps xfonts-100dpi xfonts-75dpi xfonts-scalable xinit xorg
xorg-docs-core xorgxrdp
Suggested packages:
mesa-utils xorg-docs x11-xfs-utils guacamole xrdp-pulseaudio-installer
The following NEW packages will be installed:
libglu1-mesa x11-apps x11-session-utils xbitmaps xfonts-100dpi xfonts-75dpi xfonts-scalable xinit xorg
xorg-docs-core xorgxrdp xrdp
0 upgraded, 12 newly installed, 0 to remove and 20 not upgraded.
Need to get 8,987 kB of archives.
After this operation, 14.7 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Get:1 http://mirror.ossplanet.net/raspbian/raspbian buster/main armhf libglu1-mesa armhf 9.0.0-2.1 [130 kB]
Get:2 http://mirror.ossplanet.net/raspbian/raspbian buster/main armhf x11-apps armhf 7.7+7 [541 kB]
Get:3 http://mirror.ossplanet.net/raspbian/raspbian buster/main armhf x11-session-utils armhf 7.7+3 [61.2 kB]
Get:4 http://mirror.ossplanet.net/raspbian/raspbian buster/main armhf xbitmaps all 1.1.1-2 [32.1 kB]
Get:5 http://mirror.ossplanet.net/raspbian/raspbian buster/main armhf xfonts-100dpi all 1:1.0.4+nmu1 [3,822 kB]
Get:6 http://mirror.ossplanet.net/raspbian/raspbian buster/main armhf xfonts-75dpi all 1:1.0.4+nmu1 [3,367 kB]
Get:7 http://mirror.ossplanet.net/raspbian/raspbian buster/main armhf xfonts-scalable all 1:1.0.3-1.1 [304 kB]
Get:8 http://mirror.ossplanet.net/raspbian/raspbian buster/main armhf xinit armhf 1.4.0-1 [49.4 kB]
Get:9 http://mirror.ossplanet.net/raspbian/raspbian buster/main armhf xorg-docs-core all 1:1.7.1-1.1 [84.0 kB]
Get:10 http://mirror.ossplanet.net/raspbian/raspbian buster/main armhf xorg armhf 1:7.7+19+b8 [38.8 kB]
Get:11 http://mirror.ossplanet.net/raspbian/raspbian buster/main armhf xorgxrdp armhf 1:0.2.9-1 [164 kB]
Get:12 http://mirror.ossplanet.net/raspbian/raspbian buster/main armhf xrdp armhf 0.9.9-1 [394 kB]
Fetched 8,987 kB in 41s (218 kB/s)
Selecting previously unselected package libglu1-mesa:armhf.
dpkg: unrecoverable fatal error, aborting:
files list file for package 'libpangoft2-1.0-0:armhf' is missing final newline
E: Sub-process /usr/bin/dpkg returned an error code (2)
pi@raspberrypi:~ $
pi@raspberrypi:~ $

MisterEd
Posts: 141
Joined: Mon Apr 16, 2018 5:28 am
Location: Huntsville, AL USA

Re: [VNC] Cannot currently show the dekstop

Sat Mar 28, 2020 11:50 am

I wanted to use VNC on my PC to work with the Pi desktop without a monitor connected to the Pi. It worked OK with my Pi 3B+ but not with my Pi 4B. Both are running Raspbian Buster.

Using my Pi 4B:
I set the resolution with: Pi Menu > Preferences > Screen Resolution
I set it to: 1920x1080 @60Hz
When I ran VNC on my PC I got the message “Cannot show the desktop”

I then set the resolution with raspi-config:
I set it to: DMT Mode 82 1920x1080 60Hz 16:9
When I ran VNC on my PC the desktop came up OK for my Pi

After getting it to work on my Pi 4B I wanted to investigate it further.

Here are the available resolutions shown with raspi-config:
Image

With a lot of experimentation I found I could set all the resolutions with raspi-config and have the desktop show up with VNC on my PC only with an extra step. The exception was 1600x1200.
1. Set the new resolution with raspi-config
2. Reboot
3. Also set the new resolution with Pi Menu > Preferences > Screen Resolution

Image
Config = raspi-config > Advanced Options > Resolutions
PSR = Pi Menu > Preferences > Screen Resolution (aka ARandR)
Final Resolution = xrandr -q

thammu
Posts: 7
Joined: Tue Dec 24, 2019 4:06 pm

Re: [VNC] Cannot currently show the dekstop

Sun Mar 29, 2020 6:37 am

'Man in a van' solution is the simplest. It automatically adds to the config.txt. For ready reference I copy it here:

sudo raspi-config
Select 7 Advanced Operations

Select 5 Resolution
choose highest available.

After rebooting if you check the config.txt, you will notice

hdmi_force_hotplug=1
hdmi_group=2
hdmi_mode=82

MisterEd
Posts: 141
Joined: Mon Apr 16, 2018 5:28 am
Location: Huntsville, AL USA

Re: [VNC] Cannot currently show the dekstop

Wed Apr 01, 2020 3:21 pm

thammu wrote:
Sun Mar 29, 2020 6:37 am
'Man in a van' solution is the simplest. It automatically adds to the config.txt. For ready reference I copy it here:

sudo raspi-config
Select 7 Advanced Operations

Select 5 Resolution
choose highest available.

After rebooting if you check the config.txt, you will notice

hdmi_force_hotplug=1
hdmi_group=2
hdmi_mode=82
I wish it was that simple. The problem is that I don't always want to boot to the highest resolution. For example if I use raspi-config and select DMT Mode 85 1280x720 and save that and reboot in VNC the resolution will be 1024x768 not the expected 1280x720.

If I check the config.txt file I find the expected resolution:
hdmi_force_hotplug=1
hdmi_group=2
hdmi_mode=85

While in VNC I then have to use Preferencs > Screen Configuration to raise the resolution to 1280x720.

mcwildsidemc
Posts: 1
Joined: Wed Apr 08, 2020 11:08 pm

Re: [VNC] Cannot currently show the dekstop

Wed Apr 08, 2020 11:22 pm

This was the fix i found that worked from be using Putty ssh. I had two issues one being my resolution was set to default and my pi was set to CL log into my pi from putty
changing to desktop fixed that issue by going

Code: Select all

sudo raspi-config

from this page going to
-3 (boot options)
-B1 (desktop/ CLI)
-B4 (Desk top Auto login.....

Then once you do that make sure to go back through and change the resolution from default to anything else
-7 (advanced Options)-
-A5 (resolution)
Pick a resolution besides the Default

from there hit okay, finish then reboot.

YodaVonBeck
Posts: 42
Joined: Wed Mar 16, 2016 10:03 am

Re: [VNC] Cannot currently show the dekstop

Sun Apr 12, 2020 5:59 pm

Fixed with change of resolution!

uahqw89
Posts: 1
Joined: Wed Apr 22, 2020 6:53 pm

Re: [VNC] Cannot currently show the dekstop

Wed Apr 22, 2020 6:59 pm

seandex wrote:
Thu Jun 27, 2019 7:46 am
klricks wrote:
Tue Jun 26, 2018 1:23 am
waayne wrote:
Mon Jun 25, 2018 9:46 pm
Hey,

I have a problem with my Pi 3+. I activated the VNC server and tried to connect to it on my tablet via the VNCViewer app.
But when I am connected to it there is an error (see attachment).
What can I do to fix that?
The RPi must be set to boot to desktop (service mode).
If a HDMI monitor is not attached then you need to specify a screen resolution in config.txt
Use GUI config tool or sudo raspi-config to do that.

If not booting to desktop then you need to use virtual mode. (Run vncserver from the command line).
Where is the example for the config.txt?
Hi guys, I'm new to this as well and just found the easy solution here, among your comments.
For those that have the black screen, try to reinstall the lxsession (you find thew code some comments above), sudo config into your RPi, go to the boot menu, and enable the desktop version.

Want to point out I'm SSH'ing and I used the hotspot.
Hopefully, that will help you get inside your desktop and start enjoying your machine :mrgreen:

camstans
Posts: 1
Joined: Sat Apr 25, 2020 2:32 am

Re: [VNC] Cannot currently show the dekstop

Sat Apr 25, 2020 2:35 am

RottenRonnie wrote:
Fri Jun 14, 2019 4:45 pm

Code: Select all

ron@raspberrypi:~ $ ls /usr/share/xsessions
lightdm-xsession.desktop  openbox.desktop
ron@raspberrypi:~ $ cat /usr/share/xsessions/lightdm-xsession.desktop 
[Desktop Entry]
Version=1.0
Name=Default Xsession
Exec=default
Icon=
Type=Application
ron@raspberrypi:~ $ sudo apt-get install --reinstall lxsession
this worked for me. thanks mate.

PoistiveCoder
Posts: 1
Joined: Thu May 07, 2020 6:11 pm

Re: [VNC] Cannot currently show the dekstop

Thu May 07, 2020 6:17 pm

klricks wrote:
Tue Jun 26, 2018 1:23 am
waayne wrote:
Mon Jun 25, 2018 9:46 pm
Hey,

I have a problem with my Pi 3+. I activated the VNC server and tried to connect to it on my tablet via the VNCViewer app.
But when I am connected to it there is an error (see attachment).
What can I do to fix that?
The RPi must be set to boot to desktop (service mode).
If a HDMI monitor is not attached then you need to specify a screen resolution in config.txt
Use GUI config tool or sudo raspi-config to do that.

If not booting to desktop then you need to use virtual mode. (Run vncserver from the command line).
For me this was the answer :)
In order to change config.txt

1. open terminal in Rasp Pi
2. type

Code: Select all

sudo raspi-config
3.Select Option 7.Advanced Options (move with arrows and press Enter)
4.Select A5.Resolution (move with arrows and press Enter)
5. Select the highest one available (anything other than default ), press enter
6. Move with arrow keys down to the Left and press Finish
(it shall ask if you want to reboot, select YES, type enter and you are ready :) )

rompelstilchen
Posts: 71
Joined: Thu Mar 03, 2016 10:37 am

Re: [VNC] Cannot currently show the dekstop

Fri May 08, 2020 10:56 am

I don't remember I had to do this before
and even though I choose the max resolution, it appears only in some 1024x700 or something
wtf?

rompelstilchen
Posts: 71
Joined: Thu Mar 03, 2016 10:37 am

Re: [VNC] Cannot currently show the dekstop

Fri May 08, 2020 10:59 am

ok I have setup the screen resolution in the parameters too, so now it starts full resolution

volcanoman
Posts: 1
Joined: Sat May 09, 2020 1:29 pm

Re: [VNC] Cannot currently show the dekstop

Sat May 09, 2020 2:13 pm

I tried this too, but I dont get a list of reolutions... there's a 'flash' onto a dark-ish screen, then it goes back to the origional menu with options 1-9. Managed to brick my first image trying to fix this with the config.txt trick (on an other thread) so I'm onto a second with s apre SD card. Surely there's an *easy* way to make the VNC work without plugging in a monitor first!

echavet
Posts: 3
Joined: Sun Jun 07, 2020 5:52 pm

Re: [VNC] Cannot currently show the dekstop

Sun Jun 07, 2020 5:53 pm

RDP (https://linuxize.com/post/how-to-instal ... pberry-pi/) worked fine for me on rasp 4 !!
Thanks

Return to “Troubleshooting”