seanspotatobusiness
Posts: 221
Joined: Tue May 22, 2012 11:19 pm

Repository to get libdb4.8++-dev?

Wed Jun 27, 2018 8:45 am

I'm trying to compile a cryptocurrency wallet on my Pi but I require "libdb4.8++-dev" and I don't know how to get it. It has "no installation candidate" in the repositories that come with Raspbian. Can anyone advise me on how to do this for the Pi? I've found instructions for other Linux distributions but nothing for the Pi (the solution I found for Ubuntu did not provide "a distribution template for Raspbian/stretch").
Raspberry Pi 3 B and B+
PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
NAME="Raspbian GNU/Linux"
VERSION_ID="10"
VERSION="10 (buster)"

fruitoftheloom
Posts: 27225
Joined: Tue Mar 25, 2014 12:40 pm

Re: Repository to get libdb4.8++-dev?

Wed Jun 27, 2018 10:04 am

seanspotatobusiness wrote:
Wed Jun 27, 2018 8:45 am
I'm trying to compile a cryptocurrency wallet on my Pi but I require "libdb4.8++-dev" and I don't know how to get it. It has "no installation candidate" in the repositories that come with Raspbian. Can anyone advise me on how to do this for the Pi? I've found instructions for other Linux distributions but nothing for the Pi (the solution I found for Ubuntu did not provide "a distribution template for Raspbian/stretch").

libdb5.3-dev should be in the Stretch Repositories

https://packages.debian.org/stretch/libdb5.3-dev
Take what I advise as advice not the utopian holy grail, and it is gratis !!

mfa298
Posts: 1386
Joined: Tue Apr 22, 2014 11:18 am

Re: Repository to get libdb4.8++-dev?

Wed Jun 27, 2018 12:00 pm

seanspotatobusiness wrote:
Wed Jun 27, 2018 8:45 am
I'm trying to compile a cryptocurrency wallet on my Pi but I require "libdb4.8++-dev" and I don't know how to get it. It has "no installation candidate" in the repositories that come with Raspbian. Can anyone advise me on how to do this for the Pi?
libdb 4.8 is pretty old now so usually isn't packaged in newer operating systems. The options are likely either:
  • compile libdb 4.8 from source.
  • use the newer libdb in Raspbian.
The newer libdb should work on most coin daemons, the issue you might find is that the database files (wallet.dat in particular) isn't compatible with all other systems if they're built on an older libdb.

Return to “Beginners”