ChriWo
Posts: 6
Joined: Mon Aug 21, 2017 10:39 am

Problem mounting network drive with fstab after change to SMB2 in NAS with jessie

Sat Aug 25, 2018 2:45 pm

Hi,

changed in the NAS from SMB1 to SMB2 with stretch I can connect to the NAS but with jessie not!

I have added in /etc/samba/smb.conf

# SMB2 and SMB3
client min protocol = SMB2
client max protocol = SMB3

content of fstab
//192.168.1.200/Temp /media/DS-Temp/ cifs defaults,username=RasTest,password=RasTest,x-systemd.automount,x-systemd.requires=network-online.target 0 0

Thanks for the help

DirkS
Posts: 10699
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: Problem mounting network drive with fstab after change to SMB2 in NAS with jessie

Sat Aug 25, 2018 3:31 pm

Maybe you need to add the vers= option (probably 'vers=2'; google for possible values)


DirkS
Posts: 10699
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: Problem mounting network drive with fstab after change to SMB2 in NAS with jessie

Sat Aug 25, 2018 4:28 pm

ChriWo wrote:
Sat Aug 25, 2018 4:24 pm
sorry not working :(
Did you investigate a bit yourself or just use my suggestion.
As I said: you need to search for valid values...

ChriWo
Posts: 6
Joined: Mon Aug 21, 2017 10:39 am

Re: Problem mounting network drive with fstab after change to SMB2 in NAS with jessie

Sat Aug 25, 2018 5:18 pm

I try since 3 days ...
I also installed the smbclient (sudo apt-get install cifs-utils smbclient)
with this i can connect to the NAS with the following command

smbclient -U RasTest%RasTest -L //192.168.1.200/

I can connect to the NAS, but with

content of fstab
//192.168.1.200/Temp /media/DS-Temp/ cifs defaults,username=RasTest,password=RasTest,x-systemd.automount,x-systemd.requires=network-online.target 0 0

(and several version=2.0, version=2, ver=2.0, ver=2)

or if I use the
sudo mount -t cifs -o vers=2,username=RasTest,password=RasTest //192.168.1.200/Temp //media/DS-Temp
sudo mount -t cifs -o version=2,username=RasTest,password=RasTest //192.168.1.200/Temp //media/DS-Temp
sudo mount -t cifs -o vers=2.0,username=RasTest,password=RasTest //192.168.1.200/Temp //media/DS-Temp
sudo mount -t cifs -o version=2.0,username=RasTest,password=RasTest //192.168.1.200/Temp //media/DS-Temp

I canot connect the the share.

ChriWo
Posts: 6
Joined: Mon Aug 21, 2017 10:39 am

Re: Problem mounting network drive with fstab after change to SMB2 in NAS with jessie

Sat Aug 25, 2018 6:22 pm

It is working ... :D

new content of fstab

//192.168.1.200/Temp /media/DS-Temp/ cifs vers=2,username=RasTest,password=RasTest,x-systemd.automount,x-systemd.requires=network-online.target 0 0

delete = defaults
add = vers=2

Return to “Troubleshooting”