Page 1 of 1

Trouble to configurate Raspberry Pi 4G Hat from Waveshare (SIM7600E-H)

Posted: Fri Jan 25, 2019 7:54 am
by Zgredinho
Guys I messed up and don't know how to fix it.

I got 4G Hat from Waveshare (SIM7600E-H) and I am using it as modem through UART, but transfer rate was terrible about 30-100 Kbps. I assumed that's because of baud rate. So I set 3686400 baud rate on SIM7600 and now I lost communication with it. When I set this baud rate in rnet file in ppp it fails because of "baud rate not supported".

I also cannot connect with minicom because it seems minicom has predefined baudrates and there is 3500000 and 4000000 but nothing in between. How can I make it works? What can I do to fix this? Is there any way to reset SIM7600 to factory settings?

(I use new raspbian)

Re: Trouble to configurate Raspberry Pi 4G Hat from Waveshare (SIM7600E-H)

Posted: Wed Apr 15, 2020 2:22 pm
by Morkxy
Hi !

I have the same problem !
Like an idiot, ...i have change the default speed to 3686400 and now I lost connexion :( (the smallest values worked... grr)

I just emailed Waveshare ... I hope I get help.

By cons I can give you the answer to your problem: yes the connection via UART will slow you down considerably. This is not the right track, you need to use the "USB" port on the board. For the moment I have only tested with a Fedora on my laptop and the speed has nothing to do!

(sorry for my English)