hippy
Posts: 12309
Joined: Fri Sep 09, 2011 10:34 pm
Location: UK

[Solved] Broken packages

Fri Feb 22, 2019 8:45 pm

Solved :Reboot then sudo apt-get dist-upgrade seems to have restored normality.

I don't recall having installed anything since my last update and upgrade a few days ago but am now getting unmet dependencies, broken package errors. Is it just me and I have screwed something up somewhere ?

Code: Select all

pi@Pi3B:~$ sudo apt-get update
Hit:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Hit:2 http://archive.raspberrypi.org/debian stretch InRelease
Reading package lists... Done 
pi@Pi3B:~$

Code: Select all

pi@Pi3B:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 vlc-bin : Depends: libvlc-bin (= 3.0.6-0+rpt1+deb9u1) but 3.0.6-0+rpt2+deb9u1 i
s to be installed
 vlc-plugin-skins2 : Depends: vlc-plugin-qt (= 3.0.6-0+rpt2+deb9u1) but 3.0.6-0+
rpt1+deb9u1 is to be installed
E: Broken packages
pi@Pi3B:~$

razimih
Posts: 1
Joined: Sat Feb 23, 2019 8:09 pm

Re: [Solved] Broken packages

Sat Feb 23, 2019 8:58 pm

Same issue on my Pi 3 B+.
Strange my other Pi 3B doesn't seem to be affected...

Return to “General discussion”