lcd1232
Posts: 1
Joined: Sun Jan 12, 2020 1:03 pm

Raspberry Pi 4 doesn't work 5 GHz Wifi

Sun Jan 12, 2020 1:09 pm

Hello. Recently I bought RPi4 and put sd card from my old RPi3. The problem is that it doesn't want to see 5GHz Wifi at all.
$ iw phy phy0 channels

Code: Select all

Band 1:
	* 2412 MHz [1]
	  Maximum TX power: 20.0 dBm
	  Channel widths: 20MHz
	* 2417 MHz [2]
	  Maximum TX power: 20.0 dBm
	  Channel widths: 20MHz
	* 2422 MHz [3]
	  Maximum TX power: 20.0 dBm
	  Channel widths: 20MHz
	* 2427 MHz [4]
	  Maximum TX power: 20.0 dBm
	  Channel widths: 20MHz
	* 2432 MHz [5]
	  Maximum TX power: 20.0 dBm
	  Channel widths: 20MHz
	* 2437 MHz [6]
	  Maximum TX power: 20.0 dBm
	  Channel widths: 20MHz
	* 2442 MHz [7]
	  Maximum TX power: 20.0 dBm
	  Channel widths: 20MHz
	* 2447 MHz [8]
	  Maximum TX power: 20.0 dBm
	  Channel widths: 20MHz
	* 2452 MHz [9]
	  Maximum TX power: 20.0 dBm
	  Channel widths: 20MHz
	* 2457 MHz [10]
	  Maximum TX power: 20.0 dBm
	  Channel widths: 20MHz
	* 2462 MHz [11]
	  Maximum TX power: 20.0 dBm
	  Channel widths: 20MHz
	* 2467 MHz [12]
	  Maximum TX power: 20.0 dBm
	  Channel widths: 20MHz
	* 2472 MHz [13]
	  Maximum TX power: 20.0 dBm
	  Channel widths: 20MHz
	* 2484 MHz [14] (disabled)
Band 2:
	* 5170 MHz [34] (disabled)
	* 5180 MHz [36] (disabled)
	* 5190 MHz [38] (disabled)
	* 5200 MHz [40] (disabled)
	* 5210 MHz [42] (disabled)
	* 5220 MHz [44] (disabled)
	* 5230 MHz [46] (disabled)
	* 5240 MHz [48] (disabled)
	* 5260 MHz [52] (disabled)
	* 5280 MHz [56] (disabled)
	* 5300 MHz [60] (disabled)
	* 5320 MHz [64] (disabled)
	* 5500 MHz [100] (disabled)
	* 5520 MHz [104] (disabled)
	* 5540 MHz [108] (disabled)
	* 5560 MHz [112] (disabled)
	* 5580 MHz [116] (disabled)
	* 5600 MHz [120] (disabled)
	* 5620 MHz [124] (disabled)
	* 5640 MHz [128] (disabled)
	* 5660 MHz [132] (disabled)
	* 5680 MHz [136] (disabled)
	* 5700 MHz [140] (disabled)
	* 5720 MHz [144] (disabled)
	* 5745 MHz [149] (disabled)
	* 5765 MHz [153] (disabled)
	* 5785 MHz [157] (disabled)
	* 5805 MHz [161] (disabled)
	* 5825 MHz [165] (disabled)
$ sudo iwlist wlan0 scan | grep ESSID
shows me only 2.4GHz networks, no 5GHz.

How to fix it?

pcmanbob
Posts: 12936
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: Raspberry Pi 4 doesn't work 5 GHz Wifi

Mon Jan 13, 2020 12:47 pm

Hi.

So was the SD card you took from your pi3 a fresh build of raspbian buster or was it an upgrade from raspbian stretch ?

as with all problems of this sort start with another SD card flash a fresh copy of raspbian buster on it and see if you can see the 5Ghz wifi then.

that's always assuming you are within range of said wifi .

Some thing else that some times causes problems it were both 2.4 and 5Ghz wifi share the same SSID resulting in the pi only seeing the better 2.4Ghz signal.
We want information… information… information........................no information no help
The use of crystal balls & mind reading are not supported

trejan
Posts: 4549
Joined: Tue Jul 02, 2019 2:28 pm

Re: Raspberry Pi 4 doesn't work 5 GHz Wifi

Mon Jan 13, 2020 1:40 pm

Run raspi-config and go to "Localisation Options" then "Change Wi-fi Country". Set it your country.

Juanca
Posts: 10
Joined: Sat May 20, 2017 2:33 am

Re: Raspberry Pi 4 doesn't work 5 GHz Wifi

Fri Jun 12, 2020 6:23 am

trejan wrote:
Mon Jan 13, 2020 1:40 pm
Run raspi-config and go to "Localisation Options" then "Change Wi-fi Country". Set it your country.
Yes Sir, you are right I changed my country code AR to the first one AD and my Rpi 4 is a happy user of 5 GHz Wifi.
Itś clear that with my country code it dosn't work ;)
Do you know the reason why?

Thanks a lot for your help!

Juanca
Posts: 10
Joined: Sat May 20, 2017 2:33 am

Re: Raspberry Pi 4 doesn't work 5 GHz Wifi

Fri Jun 12, 2020 6:24 am

trejan wrote:
Mon Jan 13, 2020 1:40 pm
Run raspi-config and go to "Localisation Options" then "Change Wi-fi Country". Set it your country.
Yes Sir, you are right I changed my country code AR to the first one AD and my Rpi 4 is a happy user of 5 GHz Wifi.
Itś clear that with my country code it dosn't work ;)
Do you know the reason why?

Thanks a lot for your help!

geev03
Posts: 288
Joined: Thu Jun 07, 2012 12:40 pm
Location: London, UK

Re: Raspberry Pi 4 doesn't work 5 GHz Wifi

Wed Oct 21, 2020 9:14 am

lcd1232 wrote:
Sun Jan 12, 2020 1:09 pm
Hello. Recently I bought RPi4 and put sd card from my old RPi3. The problem is that it doesn't want to see 5GHz Wifi at all.
$ iw phy phy0 channels

$ sudo iwlist wlan0 scan | grep ESSID
shows me only 2.4GHz networks, no 5GHz.

How to fix it?
Upgrade the Kernel to 5.9 and 5GHz wifi connection comes automatically..

Code: Select all

root@raspberrypi:~# iw phy phy0 channels
Band 1:
        * 2412 MHz [1]
          Maximum TX power: 20.0 dBm
          Channel widths: 20MHz HT40+
        * 2417 MHz [2]
          Maximum TX power: 20.0 dBm
          Channel widths: 20MHz HT40+
        * 2422 MHz [3]
          Maximum TX power: 20.0 dBm
          Channel widths: 20MHz HT40+
        * 2427 MHz [4]
          Maximum TX power: 20.0 dBm
          Channel widths: 20MHz HT40+
        * 2432 MHz [5]
          Maximum TX power: 20.0 dBm
          Channel widths: 20MHz HT40- HT40+
        * 2437 MHz [6]
          Maximum TX power: 20.0 dBm
          Channel widths: 20MHz HT40- HT40+
        * 2442 MHz [7]
          Maximum TX power: 20.0 dBm
          Channel widths: 20MHz HT40- HT40+
        * 2447 MHz [8]
          Maximum TX power: 20.0 dBm
          Channel widths: 20MHz HT40- HT40+
        * 2452 MHz [9]
          Maximum TX power: 20.0 dBm
          Channel widths: 20MHz HT40- HT40+
        * 2457 MHz [10]
          Maximum TX power: 20.0 dBm
          Channel widths: 20MHz HT40-
        * 2462 MHz [11]
          Maximum TX power: 20.0 dBm
          Channel widths: 20MHz HT40-
        * 2467 MHz [12]
          Maximum TX power: 20.0 dBm
          Channel widths: 20MHz HT40-
        * 2472 MHz [13]
          Maximum TX power: 20.0 dBm
          Channel widths: 20MHz HT40-
        * 2484 MHz [14] (disabled)
Band 2:
        * 5170 MHz [34] (disabled)
        * 5180 MHz [36]
          Maximum TX power: 20.0 dBm
          Channel widths: 20MHz HT40+
        * 5190 MHz [38] (disabled)
        * 5200 MHz [40]
          Maximum TX power: 20.0 dBm
          Channel widths: 20MHz HT40-
        * 5210 MHz [42] (disabled)
        * 5220 MHz [44]
          Maximum TX power: 20.0 dBm
          Channel widths: 20MHz HT40+
        * 5230 MHz [46] (disabled)
        * 5240 MHz [48]
          Maximum TX power: 20.0 dBm
          Channel widths: 20MHz HT40-
        * 5260 MHz [52]
          Maximum TX power: 20.0 dBm
          No IR
          Radar detection
          Channel widths: 20MHz HT40+
          DFS state: usable (for 560 sec)
          DFS CAC time: 60000 ms
        * 5280 MHz [56]
          Maximum TX power: 20.0 dBm
          No IR
          Radar detection
          Channel widths: 20MHz HT40-
          DFS state: usable (for 560 sec)
          DFS CAC time: 60000 ms
        * 5300 MHz [60]
          Maximum TX power: 20.0 dBm
          No IR
          Radar detection
          Channel widths: 20MHz HT40+
          DFS state: usable (for 560 sec)
          DFS CAC time: 60000 ms
        * 5320 MHz [64]
          Maximum TX power: 20.0 dBm
          No IR
          Radar detection
          Channel widths: 20MHz HT40-
          DFS state: usable (for 560 sec)
          DFS CAC time: 60000 ms
        * 5500 MHz [100]
          Maximum TX power: 20.0 dBm
          No IR
          Radar detection
          Channel widths: 20MHz HT40+
          DFS state: usable (for 560 sec)
          DFS CAC time: 60000 ms
        * 5520 MHz [104]
          Maximum TX power: 20.0 dBm
          No IR
          Radar detection
          Channel widths: 20MHz HT40-
          DFS state: usable (for 560 sec)
          DFS CAC time: 60000 ms
        * 5540 MHz [108]
          Maximum TX power: 20.0 dBm
          No IR
          Radar detection
          Channel widths: 20MHz HT40+
          DFS state: usable (for 560 sec)
          DFS CAC time: 60000 ms
        * 5560 MHz [112]
          Maximum TX power: 20.0 dBm
          No IR
          Radar detection
          Channel widths: 20MHz HT40-
          DFS state: usable (for 560 sec)
          DFS CAC time: 60000 ms
        * 5580 MHz [116]
          Maximum TX power: 20.0 dBm
          No IR
          Radar detection
          Channel widths: 20MHz HT40+
          DFS state: usable (for 560 sec)
          DFS CAC time: 60000 ms
        * 5600 MHz [120]
          Maximum TX power: 20.0 dBm
          No IR
          Radar detection
          Channel widths: 20MHz HT40-
          DFS state: usable (for 560 sec)
          DFS CAC time: 60000 ms
        * 5620 MHz [124]
          Maximum TX power: 20.0 dBm
          No IR
          Radar detection
          Channel widths: 20MHz HT40+
          DFS state: usable (for 560 sec)
          DFS CAC time: 60000 ms
        * 5640 MHz [128]
          Maximum TX power: 20.0 dBm
          No IR
          Radar detection
          Channel widths: 20MHz HT40-
          DFS state: usable (for 560 sec)
          DFS CAC time: 60000 ms
        * 5660 MHz [132]
          Maximum TX power: 20.0 dBm
          No IR
          Radar detection
          Channel widths: 20MHz HT40+
          DFS state: usable (for 560 sec)
          DFS CAC time: 60000 ms
        * 5680 MHz [136]
          Maximum TX power: 20.0 dBm
          No IR
          Radar detection
          Channel widths: 20MHz HT40-
          DFS state: usable (for 560 sec)
          DFS CAC time: 60000 ms
        * 5700 MHz [140]
          Maximum TX power: 20.0 dBm
          No IR
          Radar detection
          Channel widths: 20MHz
          DFS state: usable (for 560 sec)
          DFS CAC time: 60000 ms
        * 5720 MHz [144] (disabled)
        * 5745 MHz [149] (disabled)
        * 5765 MHz [153] (disabled)
        * 5785 MHz [157] (disabled)
        * 5805 MHz [161] (disabled)
        * 5825 MHz [165] (disabled)
root@raspberrypi:~#
This is my setup now

Code: Select all

root@raspberrypi:~# neofetch
  `.::///+:/-.        --///+//-:``    root@raspberrypi
 `+oooooooooooo:   `+oooooooooooo:    ----------------
  /oooo++//ooooo:  ooooo+//+ooooo.    OS: Raspbian GNU/Linux 10 (buster) armv7l
  `+ooooooo:-:oo-  +o+::/ooooooo:     Host: Raspberry Pi 4 Model B Rev 1.1
   `:oooooooo+``    `.oooooooo+-      Kernel: 5.9.0-v7l+
     `:++ooo/.        :+ooo+/.`       Uptime: 12 mins
        ...`  `.----.` ``..           Packages: 2068 (dpkg), 4 (snap)
     .::::-``:::::::::.`-:::-`        Shell: bash 5.0.3
    -:::-`   .:::::::-`  `-:::-       CPU: BCM2711 (4) @ 1.500GHz
   `::.  `.--.`  `` `.---.``.::`      Memory: 199MiB / 3826MiB
       .::::::::`  -::::::::` `
 .::` .:::::::::- `::::::::::``::.
-:::` ::::::::::.  ::::::::::.`:::-
::::  -::::::::.   `-::::::::  ::::
-::-   .-:::-.``....``.-::-.   -::-
 .. ``       .::::::::.     `..`..
   -:::-`   -::::::::::`  .:::::`
   :::::::` -::::::::::` :::::::.
   .:::::::  -::::::::. ::::::::
    `-:::::`   ..--.`   ::::::.
      `...`  `...--..`  `...`
            .::::::::::
             `.-::::-`

root@raspberrypi:~# lsblk
NAME   MAJ:MIN RM  SIZE RO TYPE MOUNTPOINT
loop0    7:0    0 62.1M  1 loop /snap/gtk-common-themes/1506
loop1    7:1    0   83M  1 loop /snap/core/10130
loop2    7:2    0 82.4M  1 loop /snap/core/9995
loop3    7:3    0 45.7M  1 loop /snap/core18/1889
sda      8:0    1 14.9G  0 disk
├─sda1   8:1    1  256M  0 part /boot
└─sda2   8:2    1 14.7G  0 part /
root@raspberrypi:~#

Return to “Networking and servers”