Hotpocketdeath
Posts: 5
Joined: Wed Mar 18, 2020 1:48 am

Rpi4 Can't connect to 5Ghz, can to 2.4Ghz

Wed Mar 18, 2020 1:56 am

So I got myself an Rpi4 the other day and trying to get it set up with Octoprint.

It doesn't connect to my 5Ghz Wifi.

This works for 2.4Ghz
## WPA/WPA2 secured
network={
ssid="FuzzyBunnyBalls"
psk="snip"
}

This does not work for 5Ghz
## WPA/WPA2 secured
network={
ssid="FuzzyBunnyBalls 5G"
psk="snip"
}

Both SSIDs use the same psk and same security settings. Neither is hidden.

I also tried it through the "sudo raspi-config" and can't connect that way either.

I wanted the Rpi4 for some extra power for lice streaming my 3D prints.

pcmanbob
Posts: 12936
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: Rpi4 Can't connect to 5Ghz, can to 2.4Ghz

Wed Mar 18, 2020 1:04 pm

Hi.

Try changing the ssid of the 5GHz wifi so that it does not include a space,

try FuzzyBunnyBalls5G or FuzzyBunnyBalls-5G
We want information… information… information........................no information no help
The use of crystal balls & mind reading are not supported

Hotpocketdeath
Posts: 5
Joined: Wed Mar 18, 2020 1:48 am

Re: Rpi4 Can't connect to 5Ghz, can to 2.4Ghz

Thu Mar 19, 2020 5:09 pm

No good, still not connecting

I just tried running the command "sudo iwlist wlan0 scan" and no SSIDs show up that are on the 5ghz range. The only ones appearing at on the 2.4ghz range

pcmanbob
Posts: 12936
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: Rpi4 Can't connect to 5Ghz, can to 2.4Ghz

Thu Mar 19, 2020 5:20 pm

Well if you pi can't see the 5GHz WiFi , could it be that you pi is just to far away from your router ?

5GHz WiFi has a much shorter range than 2.4GHz WiFi
We want information… information… information........................no information no help
The use of crystal balls & mind reading are not supported

Hotpocketdeath
Posts: 5
Joined: Wed Mar 18, 2020 1:48 am

Re: Rpi4 Can't connect to 5Ghz, can to 2.4Ghz

Thu Mar 19, 2020 5:24 pm

That's not it.

My Rpi is on my desk right now and the Access point is sitting on a shelf above my desk. Less than 3 feet distance between them.

Okay, I ran the scan again and it picks up a 5ghz access point, which must belong to a neighbor. The signal strength is fairly weak. But my own access point isn't showing up in the list.

Tried "FuzzyBunnyBalls 5G" and "FuzzyBunnyBalls-5G"

Hotpocketdeath
Posts: 5
Joined: Wed Mar 18, 2020 1:48 am

Re: Rpi4 Can't connect to 5Ghz, can to 2.4Ghz

Thu Mar 19, 2020 5:34 pm

Might have figured it out.

My 5GHz SSID was in the high range. Channels 149-161

When I dropped it down to the low range (channels 36-48), it now see's it in the scan.

Went into Raspi-Config and it connects now.

I guess the Rpi4 is much more limited in 5G than I thought.

User avatar
FTrevorGowen
Forum Moderator
Forum Moderator
Posts: 6861
Joined: Mon Mar 04, 2013 6:12 pm
Location: Bristol, U.K.

Re: Rpi4 Can't connect to 5Ghz, can to 2.4Ghz

Thu Mar 19, 2020 7:28 pm

Hotpocketdeath wrote:
Thu Mar 19, 2020 5:34 pm
Might have figured it out.

My 5GHz SSID was in the high range. Channels 149-161

When I dropped it down to the low range (channels 36-48), it now see's it in the scan.

Went into Raspi-Config and it connects now.

I guess the Rpi4 is much more limited in 5G than I thought.
May also depend on the country code which you did set didn't you? Historically I've always tried to setup any WiFi router to avoid neighbour's channels rather than, if ISP provided, the default "out of the box". Something like the mobile/tablet WiFi Analyzer app. is very useful for that: https://www.cpmspectrepi.uk/raspberry_p ... tApps.html
Trev.
Still running Raspbian Jessie or Stretch on some older Pi's (an A, B1, 2xB2, B+, P2B, 3xP0, P0W, 2xP3A+, P3B, B+, and a A+) but Buster on the P3B+, P4B's & P400. See: https://www.cpmspectrepi.uk/raspberry_pi/raspiidx.htm

Hotpocketdeath
Posts: 5
Joined: Wed Mar 18, 2020 1:48 am

Re: Rpi4 Can't connect to 5Ghz, can to 2.4Ghz

Thu Mar 19, 2020 8:10 pm

FTrevorGowen wrote:
Thu Mar 19, 2020 7:28 pm
Hotpocketdeath wrote:
Thu Mar 19, 2020 5:34 pm
Might have figured it out.

My 5GHz SSID was in the high range. Channels 149-161

When I dropped it down to the low range (channels 36-48), it now see's it in the scan.

Went into Raspi-Config and it connects now.

I guess the Rpi4 is much more limited in 5G than I thought.
May also depend on the country code which you did set didn't you? Historically I've always tried to setup any WiFi router to avoid neighbour's channels rather than, if ISP provided, the default "out of the box". Something like the mobile/tablet WiFi Analyzer app. is very useful for that: https://www.cpmspectrepi.uk/raspberry_p ... tApps.html
Trev.
Yeah, I've been using Wifi Analyzer on my phone. And I don't use an ISP provided Wifi access point, it's my own. Netgear Nighthawk, but I plan on upgrading to Ubiquiti in the future.

And what country code are you referring to? I've never needed to be concerned with that on any of my equipment before.

Edit: Foolish me, the country code fixed it. The Rpi4 can see the Wifi in the high channels after I went back and set the country code. New one on me. Looks like that was a recent requirement change when I went back at looked deeper at some of the guides.

User avatar
FTrevorGowen
Forum Moderator
Forum Moderator
Posts: 6861
Joined: Mon Mar 04, 2013 6:12 pm
Location: Bristol, U.K.

Re: Rpi4 Can't connect to 5Ghz, can to 2.4Ghz

Thu Mar 19, 2020 8:27 pm

Hotpocketdeath wrote:
Thu Mar 19, 2020 8:10 pm
FTrevorGowen wrote:
Thu Mar 19, 2020 7:28 pm
...
May also depend on the country code which you did set didn't you? Historically I've always tried to setup any WiFi router to avoid neighbour's channels rather than, if ISP provided, the default "out of the box". Something like the mobile/tablet WiFi Analyzer app. is very useful for that: https://www.cpmspectrepi.uk/raspberry_p ... tApps.html
Trev.
Yeah, I've been using Wifi Analyzer on my phone. And I don't use an ISP provided Wifi access point, it's my own. Netgear Nighthawk, but I plan on upgrading to Ubiquiti in the future.

And what country code are you referring to? I've never needed to be concerned with that on any of my equipment before.

Edit: Foolish me, the country code fixed it. The Rpi4 can see the Wifi in the high channels after I went back and set the country code. New one on me. Looks like that was a recent requirement change when I went back at looked deeper at some of the guides.
Some WiFi channels are "illegal"** in some countries. Setting the country code enables all the "legal" ones for that country. IIRC it mainly (if not only) applies to 5Ghz WiFi (and thus didn't apply to older Pi's which only had 2.4GHz WiFi or none at all).
Trev.
** IE. probably clash with other, reserved (for the ...) usage.
Still running Raspbian Jessie or Stretch on some older Pi's (an A, B1, 2xB2, B+, P2B, 3xP0, P0W, 2xP3A+, P3B, B+, and a A+) but Buster on the P3B+, P4B's & P400. See: https://www.cpmspectrepi.uk/raspberry_pi/raspiidx.htm

Return to “Troubleshooting”