Page 1 of 1

X11 Forwarding SSH

Posted: Sat Dec 29, 2012 12:31 am
by Axolotl9250
Hi I've been reading this post:

http://raspberry-python.blogspot.co.uk/ ... ekick.html

I'm under the impression this will eliminate the need for VNC if I connect to my pi via ssh on my mac or windows machine. It seems to have been done in debian however and I'm struggling to achieve it in Arch.

So far I've made sure the openssh daemon runs on bootup by enabling it with the systemctl command.

# systemctl enable sshd.socket

I've checked the wiki for opens and have made the following changes to the two configuration files:
In /etc/ssh/sshd_config
#AllowTcpForwarding yes
#X11Forwarding yes
#X11DisplayOffset 10
#X11UseLocalhost yes

In /etc/ssh/ssh_config
#ForwardX11 yes

I've rebooted my Pi and on my mac terminal:
CODE: SELECT ALL
ssh -X ben@PI_IP_ADDRESS

However if I then, from my session, start a graphical program such as midori, I get:

Midori - Cannot open display:

and if I startx on the ssh session, the desktop does indeed show up, not on my Mac as desired, but on a telly if I plug one into the HDMI slot.

I'm pretty confused, xhost + in the ssh session or in the terminal of a x session running on tty1 of my pi does not help things.

I'm not sure if I haven't completed all steps necessary to correctly configure this, I don't have any complicated DM, only open box, according to the author of the blog post (he also make a thread on the pi forums about doing this) it should work no problem with very little tweaking. I don't know if the problem is with my mac or the pi/arch setup. I know X11 on mountain lion has moved to something called the XQuartz project, I'm probably being dim - I suspect this needs installing first, but again, the instructions in the post and blog don't mention this as a requirement in the mac/linux/solaris section.

Thanks,
Ben.

[EDIT]
XQuartz is installed but starting up my ssh session I see "X11 forwarding request failed on channel 0"

Re: X11 Forwarding SSH

Posted: Sun Dec 30, 2012 3:43 pm
by benjaminc1
If you edited your sshd_config file like it is posted here, you need to uncomment (remove the # in front of) those lines, otherwise the changes will not have any effect.

Code: Select all

AllowTcpForwarding yes
X11Forwarding yes
Don't forget to restart the service/reboot the RPi. Try with those two options first and see if it works. I don't think you need the other two as well.