KarelHusa
Posts: 2
Joined: Thu May 21, 2020 6:56 am

RPI4 cannot connect to WIFI - status_code=16

Thu May 21, 2020 5:23 pm

Hello guys,
I am trying to set up wifi on my brand new RPI4.

When I try to connect to my WildGooseCZ_EXT network (provided by a Netgear extender 3m away from my RPI4) with wpa_cli, I get the following error:
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>WPS-AP-AVAILABLE
<3>CTRL-EVENT-SSID-REENABLED id=0 ssid="WildGooseCZ_EXT"
<3>Trying to associate with SSID 'WildGooseCZ_EXT'
<3>CTRL-EVENT-ASSOC-REJECT bssid=00:00:00:00:00:00 status_code=16
<3>CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="WildGooseCZ_EXT" auth_failures=6 duration=90 reason=CONN_FAILED

Can you please help me to understand, what does status_code=16 mean? I could not find the status code description. I have checked the password several times and it's OK. Also, I am using this wifi on my laptop on daily basis.

Surprisingly, I am able to connect to my mobile phone hotspot (GooseMobile network in the listing bellow), whose attributes are almost identical, as given bellow.

Any help is appreciated.

Best regards,
Karel

pi@raspberrypi:~ $ cat /etc/wpa_supplicant/wpa_supplicant.conf
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=CZ

network={
ssid="WildGooseCZ_EXT"
psk="ZZZZZ"
key_mgmt=WPA-PSK
}

network={
ssid="GooseMobile"
psk="ZZZZZ"
key_mgmt=WPA-PSK
disabled=1
}

pi@raspberrypi:~ $ sudo iwlist wlan0 scan
wlan0 Scan completed :
Cell 01 - Address: 84:38:38:E6:41:C9
Channel:6
Frequency:2.437 GHz (Channel 6)
Quality=70/70 Signal level=-24 dBm
Encryption key:on
ESSID:"GooseMobile"
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s
Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
Mode:Master
Extra:tsf=0000000000000000
Extra: Last beacon: 100ms ago
IE: Unknown: 000B476F6F73654D6F62696C65
IE: Unknown: 010882848B962430486C
IE: Unknown: 030106
IE: Unknown: 2A0104
IE: Unknown: 2F0104
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : CCMP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
IE: Unknown: 32040C121860
IE: Unknown: 2D1A2D1017FF00000000000000000000000000000000000000000000
IE: Unknown: 3D1606080400000000000000000000000000000000000000
IE: Unknown: 7F080000000000000040
IE: Unknown: DD050016328000
IE: Unknown: DD090010180201001C0000
IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00
IE: Unknown: DD1E00904C0408BF0C32008003FEFF0000FEFF0000C0050006000000C3020002
Cell 02 - Address: 08:36:C9:25:E3:5D
Channel:13
Frequency:2.472 GHz (Channel 13)
Quality=66/70 Signal level=-44 dBm
Encryption key:on
ESSID:"WildGooseCZ_EXT"
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s
18 Mb/s; 36 Mb/s; 54 Mb/s
Bit Rates:6 Mb/s; 12 Mb/s; 24 Mb/s; 48 Mb/s
Mode:Master
Extra:tsf=0000000000000000
Extra: Last beacon: 100ms ago
IE: Unknown: 000F57696C64476F6F7365435A5F455854
IE: Unknown: 010882848B961224486C
IE: Unknown: 03010D
IE: Unknown: 32040C183060
IE: Unknown: 0706444520010D14
IE: Unknown: 33082001020304050607
IE: Unknown: 33082105060708090A0B
IE: Unknown: 050400010000
IE: Unknown: DD310050F204104A0001101044000101104700102880288028801880A8800836C925E35D103C0001011049000600372A000120
IE: Unknown: 2A0100
IE: Unknown: 2D1AEC0117FFFF000000000000000000000000000000000000000000
IE: Unknown: 3D160D000000000000000000000000000000000000000000
IE: Unknown: 7F0101
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : CCMP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
IE: Unknown: DD180050F2020101000003A4000027A4000042435E0062322F00
IE: Unknown: 0B05000014127A
IE: Unknown: DD07000C430300

KarelHusa
Posts: 2
Joined: Thu May 21, 2020 6:56 am

Re: RPI4 cannot connect to WIFI - status_code=16

Fri May 22, 2020 11:01 am

I have found the root cause -- and surprisingly it's wifi-HDMI interference of RPI4.

Though I have known about this issue, I believed it's not my case, because:
- I was able to connect to another wifi (mobile hotspot)
- my resolution was only 1920x1080

When I lowered screen resolution to 1600x1200, wifi started to work with both of my networks.

Best regards,
Karel

claymore666
Posts: 2
Joined: Thu Dec 03, 2020 2:17 pm

Re: RPI4 cannot connect to WIFI - status_code=16

Thu Dec 03, 2020 2:43 pm

Thank you for sharing this. I was wondering after a reboot and a usb m2 drive swap why my machine wasn't comming up again.
Turns out I have the same WIFI connection issue you mentioned.
Deplugging the HDMI cable and replugging it again after 5 seconds of joining a network via wpa_supplicant fixed the issue.

In /boot/config.txt I am forcing HDMI group 2 and mode 82.
I am running console mode without any X server.
It works againwhen I reboot using only the right HDMI connector, and spare the one right to the USB-C power out. :shock:

Return to “Troubleshooting”