march1993
Posts: 2
Joined: Wed May 27, 2020 6:53 am

can't boot from SD card with uart log

Wed May 27, 2020 7:01 am

It's quite weird. I can burn a recovery image to the card and pi4b accepted it. But when I put the linux system inside, pi4b complained it could not read from the sdcard.
Here's the detail debug message,

Code: Select all

PM_RSTS: 0x00001000
RPi: BOOTLOADER release VERSION:23a9f59b DATE: May 15 2020 TIME: 11:05:55 BOOTMODE: 0x00000006 part: 0 BUILD_TIMESTAMP=1589537152 0x6fa2fca0 0x00b03111
uSD voltage 3.3V
Initialising SDRAM 'Micron' 16Gb x1 total-size: 16 Gbit 3200
Boot mode: SD (01) order f4
SD HOST: 250000000 CTL0: 0x00000000 BUS: 100000 Hz actual: 100000 HZ div: 2500 (1250) status: 0x1fff0000 delay: 1080
SD HOST: 250000000 CTL0: 0x00000f00 BUS: 100000 Hz actual: 100000 HZ div: 2500 (1250) status: 0x1fff0000 delay: 1080
CID: 00035344534333324780dd12300f013c
CSD: 400e00325b590000edc87f800a404000
SD: bus-width: 4 spec: 2 SCR: 0x02358043 0x00000000
SD HOST: 250000000 CTL0: 0x00000f04 BUS: 50000000 Hz actual: 41666666 HZ div: 6 (3) status: 0x1fff0000 delay: 2
SD CMD: 0x371a0010 (55) 0xaaaa0000 0x1fff0001
Failed to open device: 'sdcard' (cmd 371a0010 status 1fff0001)
Retry SD 1/1
I've tried stable and beta firmware, both won't work.
The problem card is accepted by another working pi4b. The problem pi4b above accepts other sdcard but all the cards are of the same model and I bought at the same time.

march1993
Posts: 2
Joined: Wed May 27, 2020 6:53 am

Re: can't boot from SD card with uart log

Wed May 27, 2020 11:29 am

I've measured the frequency of the sd bus when no card is inserted. The problem board generates a 442.6KHz idle frequency, which is supposed to be 100KHz.

Wronglebowski
Posts: 6
Joined: Tue Jun 16, 2020 5:04 am

Re: can't boot from SD card with uart log

Tue Jun 16, 2020 5:08 am

I'm having the same exact issue, I feel like it's clearly an issue with the firmware but without reading SD cards how can you update?

Return to “Troubleshooting”