renyhp
Posts: 1
Joined: Sat Nov 21, 2020 9:03 am

Problem installing package from testing repository (unmet dependencies / Breaks)

Sat Nov 21, 2020 5:12 pm

I am on a RPi4, Raspberry Pi OS (buster).

I'm trying to install one single package (lilypond) from the testing repository. I'm trying to be super careful as I don't want to break anything in my system.

First of all, I set up apt in the following way.
This is /etc/apt/sources.list.d/:

Code: Select all

#buster.list
deb http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi

#raspi.list
deb http://archive.raspberrypi.org/debian/ buster main

#testing.list
deb http://raspbian.raspberrypi.org/raspbian/ testing main contrib non-free rpi
And this is /etc/apt/preferences.d/:

Code: Select all

#buster.pref
Package: *
Pin: release a=buster
Pin-Priority: 900

#testing.pref
Package: *
Pin: release a=testing,n=bullseye
Pin-Priority: 101
After sudo apt update everything seems to be up to date, as it should.

Now this is the problem:

Code: Select all

$ sudo apt install --dry-run -t testing lilypond
[...]
The following packages have unmet dependencies:
 libc6-dev : Breaks: libgcc-8-dev (< 8.4.0-2~) but 8.3.0-6+rpi1 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
This is strange to me, as both these commands:

Code: Select all

apt depends --recurse --no-recommends --no-suggests --no-conflicts --no-breaks --no-replaces --no-enhances -t testing lilypond | grep libc6-dev
apt depends --recurse --no-recommends --no-suggests --no-conflicts --no-breaks --no-replaces --no-enhances -t testing lilypond | grep libgcc-8-dev
show no results, so I don't understand why installing lilypond should create unmet dependencies regarding these two packages.

Can anyone give me a hand on how to proceed? Thank you!

fruitoftheloom
Posts: 27226
Joined: Tue Mar 25, 2014 12:40 pm

Re: Problem installing package from testing repository (unmet dependencies / Breaks)

Sun Nov 22, 2020 8:40 pm

renyhp wrote:
Sat Nov 21, 2020 5:12 pm
I am on a RPi4, Raspberry Pi OS (buster).

I'm trying to install one single package (lilypond) from the testing repository. I'm trying to be super careful as I don't want to break anything in my system.

First of all, I set up apt in the following way.
This is /etc/apt/sources.list.d/:

Code: Select all

#buster.list
deb http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi

#raspi.list
deb http://archive.raspberrypi.org/debian/ buster main

#testing.list
deb http://raspbian.raspberrypi.org/raspbian/ testing main contrib non-free rpi
And this is /etc/apt/preferences.d/:

Code: Select all

#buster.pref
Package: *
Pin: release a=buster
Pin-Priority: 900

#testing.pref
Package: *
Pin: release a=testing,n=bullseye
Pin-Priority: 101
After sudo apt update everything seems to be up to date, as it should.

Now this is the problem:

Code: Select all

$ sudo apt install --dry-run -t testing lilypond
[...]
The following packages have unmet dependencies:
 libc6-dev : Breaks: libgcc-8-dev (< 8.4.0-2~) but 8.3.0-6+rpi1 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
This is strange to me, as both these commands:

Code: Select all

apt depends --recurse --no-recommends --no-suggests --no-conflicts --no-breaks --no-replaces --no-enhances -t testing lilypond | grep libc6-dev
apt depends --recurse --no-recommends --no-suggests --no-conflicts --no-breaks --no-replaces --no-enhances -t testing lilypond | grep libgcc-8-dev
show no results, so I don't understand why installing lilypond should create unmet dependencies regarding these two packages.

Can anyone give me a hand on how to proceed? Thank you!

Raspberry Pi ARMHF Operating System is based of Raspbian OS which is a fork of Debian ARMHF, therefore you are mixing 2 Linux Distros.


Raspberry Pi ARM64 Beta Operating System is based of Debian Buster Lite with the Raspberry Pi Desktop desktop environment.
Take what I advise as advice not the utopian holy grail, and it is gratis !!

User avatar
rpdom
Posts: 19280
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: Problem installing package from testing repository (unmet dependencies / Breaks)

Mon Nov 23, 2020 6:14 am

fruitoftheloom wrote:
Sun Nov 22, 2020 8:40 pm
Raspberry Pi ARMHF Operating System is based of Raspbian OS which is a fork of Debian ARMHF, therefore you are mixing 2 Linux Distros.
Where? All I see is setup for Raspberry Pi OS 32-bit armhf "Buster" with an additional source for the armhf Raspbian testing "Bullseye" repository.

I would have used bullseye instead of testing in the source line, but that's not important right now (it will be later).

It may be that there are problems with installing this package in bullseye at the moment. I will get my "bullseye" test Pi running and have a look.
I just realised that test Pi is no use as it is running a full bullseye system. What I need to do is set up a buster system and then add bullseye to it.
I'll give that a go shortly, if I can find a spare uSD card.
Unreadable squiggle

User avatar
rpdom
Posts: 19280
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: Problem installing package from testing repository (unmet dependencies / Breaks)

Mon Nov 23, 2020 8:50 am

rpdom wrote:
Mon Nov 23, 2020 6:14 am
What I need to do is set up a buster system and then add bullseye to it.
I'll give that a go shortly, if I can find a spare uSD card.
Right, done that. By adding some of the dependencies to the install I've made some progress

Code: Select all

sudo apt --dry-run -t bullseye install lilypond libgcc-8-dev gcc-8-base
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libfl2 libisl19 libperl5.28 perl-modules-5.24 perl-modules-5.28
Use 'apt autoremove' to remove them.
The following additional packages will be installed:
  binutils binutils-arm-linux-gnueabihf binutils-common cpp-8 fonts-urw-base35 gcc-10-base gcc-8
...
    loads more stuff here
...
Conf t1utils (1.41-4 Raspbian:testing [armhf])
Conf texlive-binaries (2020.20200327.54578-5 Raspbian:testing [armhf])
Conf lilypond-data (2.20.0-2 Raspbian:testing [all])
Conf lilypond (2.20.0-2 Raspbian:testing [armhf])
E: Could not configure 'libc6:armhf'. 
E: Could not perform immediate configuration on 'libnss-nis:armhf'. Please see man 5 apt.conf under APT::Immediate-Configure for details. (2)
Now, whether that's due to an issue with bullseye or a result of mixing two release versions (probably the latter) I don't know.
Certainly mixing releases isn't recommended (but not as bad as mixing distros).

When I try running that command on a full bullseye system it works.

Next to try is actually installing the software to see if that works better than a dry-run. Working on that now.
Unreadable squiggle

User avatar
rpdom
Posts: 19280
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: Problem installing package from testing repository (unmet dependencies / Breaks)

Mon Nov 23, 2020 9:06 am

The actual install gave the same error messages. I then ran dpkg-reconfigure libc6 and apt -f install and it's no longer showing any errors.
Whether this means everything is installed correctly I'm not sure.

When I type the lilypond command it comes up with some usage instructions and the correct version number.

If you really need that version I'd say: Back up your system to another SD card. Run the install. Test everything thoroughly.
Unreadable squiggle

Return to “Troubleshooting”