ljn
Posts: 9
Joined: Wed Oct 14, 2015 1:39 pm

Turning off bootup audio message

Fri Dec 04, 2020 4:25 pm

I've recently installed Raspberry Pi OS 'buster' on my pi 2. I now find that when I boot up with a USB audio adaptor in place I get the audio message 'to install the screen reader, press control alt space' repeated incessantly at 15s intervals. Can someone please tell me how to turn this off before I go completely bonkers!?

As a supplementary suggestion to whichever well-meaning bright spark decided to include the message, how about adding something to it like '...to disable this message do blah blah blah'.

timg236
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 1059
Joined: Thu Jun 21, 2018 4:30 pm

Re: Turning off bootup audio message

Fri Dec 04, 2020 10:20 pm

Close the initial settings wizard window

ljn
Posts: 9
Joined: Wed Oct 14, 2015 1:39 pm

Re: Turning off bootup audio message

Sat Dec 05, 2020 2:12 pm

I was using a headless pi accessed via ssh, so there wasn't such a window. Sorry; I should've said but was half bonkers by then!

In the event I connected the pi to a monitor and keyboard and had a play. When I went back to ssh I found that the audio message had been turned off so I'd probably inadvertently done what you suggest! Thanks for your comment.

It would still be useful to know how to disable the message with a headless system (and have that method added to the message itself!).

timg236
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 1059
Joined: Thu Jun 21, 2018 4:30 pm

Re: Turning off bootup audio message

Sat Dec 05, 2020 3:17 pm

There's probably a cleaner method but this worked for me

Code: Select all

sudo mv /usr/share/piwiz/srprompt.wav /usr/share/piwiz/srprompt.wav.bak

trejan
Posts: 4739
Joined: Tue Jul 02, 2019 2:28 pm

Re: Turning off bootup audio message

Sat Dec 05, 2020 3:39 pm

If you want to stop it immediately via SSH then kill the piwiz process.

You can stop it from running the piwiz initial setup wizard by doing "sudo rm -f /etc/xdg/autostart/piwiz.desktop"

leveret25
Posts: 1
Joined: Sat Apr 10, 2021 1:37 pm

Re: Turning off bootup audio message

Sat Apr 10, 2021 2:04 pm

I am running Rasp OS
5.10.17-v7+ #1403 SMP Mon Feb 22 11:29:51 GMT 2021 armv7l GNU/Linux

I am connecting via SSH.

I noticed the messages:
Playing WAVE '/usr/share/piwiz/srprompt.wav' : Signed 16 bit Little Endian, Rate 22050 Hz, Mono
Playing WAVE '/usr/share/piwiz/srprompt.wav' : Signed 16 bit Little Endian, Rate 22050 Hz, Mono
Playing WAVE '/usr/share/piwiz/srprompt.wav' : Signed 16 bit Little Endian, Rate 22050 Hz, Mono

in the /home/pi/.cache/lxsession/LXDE-pi/run.log file

new messages appear every minute and the run.log file grows in size. If left unchecked the run.log file will get very large.

My goal is to run monitoring scripts using cron and never connect via a monitor and keyboard.
While rebooting the device clears the run.log file, I was hoping to run this device 24x7 to collect data.

How can I disable this entry in the run.log file?

Return to “General discussion”