crimson0ninja
Posts: 3
Joined: Sun Jul 04, 2021 11:48 pm

This board requires newer software

Sun Jul 04, 2021 11:58 pm

I have a raspberry pi 4 4gb that has an image that i got from arcade punks on retro pie. i now have a second raspberry pi but its the 4 8 gb. i downloaded and etched the raspberry pi os on 1 sd and installed it. then i also downloaded retropie and installed it. i took the sd card out of the 4 gb and put in the 8 gb. now i get a message saying this board needs newer software. i made sure i did the upgrade with the raspberry os. what am i doing wrong?

terribleted
Posts: 710
Joined: Tue Oct 06, 2020 8:07 pm

Re: This board requires newer software

Mon Jul 05, 2021 1:54 pm

probably needs an eeprom update.

sudo rpi-eeprom-update
(to see status)

sudo rpi-eeprom-update -a
(to automatically update)

see "sudo rpi-eeprom-update --help" for more info
i had a Trash-80 model 1 (circa 1980). upgrading from 4k to 16k of RAM, i thought "i'll never use this much RAM".
Now i have a computer with a million times that much memory. And i keep running out of it.
Not the computer....ME.

crimson0ninja
Posts: 3
Joined: Sun Jul 04, 2021 11:48 pm

Re: This board requires newer software

Thu Jul 08, 2021 7:44 pm

Thanks for the help.

girlintrouble
Posts: 37
Joined: Fri Apr 10, 2020 9:00 pm
Location: UK

Re: This board requires newer software

Thu Jul 08, 2021 11:21 pm

I had this same error when trying to install OSMC but not with installing Raspbian on same hw. Hmm strange :geek:
We all have to start somewhere…. :mrgreen:, thank you for your patience! :D

trejan
Posts: 4549
Joined: Tue Jul 02, 2019 2:28 pm

Re: This board requires newer software

Thu Jul 08, 2021 11:31 pm

crimson0ninja wrote:
Sun Jul 04, 2021 11:58 pm
I have a raspberry pi 4 4gb that has an image that i got from arcade punks on retro pie. i now have a second raspberry pi but its the 4 8 gb.
It isn't the EEPROM. You either need to manually update your image to the latest firmware + kernel or ask for an updated image. Ask whoever you got the image from for help.

Pi 4 8GB needs newer firmware than the older 4GB model which is why the bootloader is complaining.
Last edited by trejan on Thu Jul 08, 2021 11:32 pm, edited 1 time in total.

trejan
Posts: 4549
Joined: Tue Jul 02, 2019 2:28 pm

Re: This board requires newer software

Thu Jul 08, 2021 11:32 pm

girlintrouble wrote:
Thu Jul 08, 2021 11:21 pm
I had this same error when trying to install OSMC but not with installing Raspbian on same hw. Hmm strange :geek:
Firmware + kernel on the OSMC card is too old.

girlintrouble
Posts: 37
Joined: Fri Apr 10, 2020 9:00 pm
Location: UK

Re: This board requires newer software

Thu Jul 08, 2021 11:49 pm

trejan wrote:
Thu Jul 08, 2021 11:32 pm
girlintrouble wrote:
Thu Jul 08, 2021 11:21 pm
I had this same error when trying to install OSMC but not with installing Raspbian on same hw. Hmm strange :geek:
Firmware + kernel on the OSMC card is too old.
Ok I’m a newbie, your answer is a bit too cryptic for me, is there a more basic version of your reply please?
What can I do to fix it?
We all have to start somewhere…. :mrgreen:, thank you for your patience! :D

girlintrouble
Posts: 37
Joined: Fri Apr 10, 2020 9:00 pm
Location: UK

Re: This board requires newer software

Thu Jul 08, 2021 11:50 pm

terribleted wrote:
Mon Jul 05, 2021 1:54 pm
probably needs an eeprom update.

sudo rpi-eeprom-update
(to see status)

sudo rpi-eeprom-update -a
(to automatically update)

see "sudo rpi-eeprom-update --help" for more info
Do I have to install raspbian, do this to update EPROMs then reinstall OMSC?
We all have to start somewhere…. :mrgreen:, thank you for your patience! :D

trejan
Posts: 4549
Joined: Tue Jul 02, 2019 2:28 pm

Re: This board requires newer software

Fri Jul 09, 2021 12:36 am

girlintrouble wrote:
Thu Jul 08, 2021 11:50 pm
Do I have to install raspbian, do this to update EPROMs then reinstall OMSC?
It won't fix it. The error is the bootloader in the EEPROM complaining that the files on your card don't support that revision of the hardware. Updating the EEPROM isn't going to do anything to the card contents.
girlintrouble wrote:
Thu Jul 08, 2021 11:49 pm
Ok I’m a newbie, your answer is a bit too cryptic for me, is there a more basic version of your reply please?
What can I do to fix it?
Best option is wait for the developers to release a newer image. OSMC doesn't have a Pi 4 release yet so there will be a lot of changes needed.

girlintrouble
Posts: 37
Joined: Fri Apr 10, 2020 9:00 pm
Location: UK

Re: This board requires newer software

Fri Jul 09, 2021 10:44 am

So are we saying if I was using the pi 4 2/gb or 4gb I may not have had this problem?

Seems from above there isn’t firm consensus about the issue….
We all have to start somewhere…. :mrgreen:, thank you for your patience! :D

trejan
Posts: 4549
Joined: Tue Jul 02, 2019 2:28 pm

Re: This board requires newer software

Fri Jul 09, 2021 10:53 am

girlintrouble wrote:
Fri Jul 09, 2021 10:44 am
So are we saying if I was using the pi 4 2/gb or 4gb I may not have had this problem?
No. There is no Pi 4 build of OSMC.
girlintrouble wrote:
Fri Jul 09, 2021 10:44 am
Seems from above there isn’t firm consensus about the issue….
Try upgrading the EEPROM if you want. It won’t fix it.

girlintrouble
Posts: 37
Joined: Fri Apr 10, 2020 9:00 pm
Location: UK

Re: This board requires newer software

Fri Jul 09, 2021 10:56 am

Ok thanks I won’t bother as you seem convinced. I’ll go with LibreElec as I was previously planning.
Thank you so much for the input.

It’s fun getting things wrong, at least you learn stuff

Also I hope the OP a didn’t mind my hijacking the post, personally I see little point in cluttering up forums with nearly identical posts.
We all have to start somewhere…. :mrgreen:, thank you for your patience! :D

Return to “Beginners”