anatomy
Posts: 59
Joined: Thu Jul 22, 2021 5:42 pm

Qt5 broken on Rpi OS 32-bit?

Tue Sep 21, 2021 8:14 pm

Whereas on 64-bit Rpi OS, which is Debian based, the webengine feature is provided, on 32-bit Qt5 I find that it is missing e.g.

Code: Select all

The following packages have unmet dependencies:
 qutebrowser-qtwebengine : Depends: libqt5webenginecore5 (>= 5.7.1) but it is not installable
                           Depends: python3-pyqt5.qtwebengine (>= 5.7) but it is not installable
There are "doc" and "data" packages but no actual code for qt5 web engine:

Code: Select all

$ apt list | grep engine | grep web
libqt5webengine-data/oldstable,now 5.11.3+dfsg-2+deb10u1 all [installed]
qtwebengine5-doc-html/oldstable 5.11.3+dfsg-2+deb10u1 all
qtwebengine5-doc/oldstable,now 5.11.3+dfsg-2+deb10u1 all [installed,automatic]
qutebrowser-qtwebengine/oldstable 1.6.1-2 all
I also notice that everywhere it says "oldstable".
Is the current 32-bit Rpi OS about to be abandoned?

Cloudcentric
Posts: 1277
Joined: Fri Sep 14, 2012 9:13 am

Re: Qt5 broken on Rpi OS 32-bit?

Tue Sep 21, 2021 8:25 pm

anatomy wrote:
Tue Sep 21, 2021 8:14 pm
Whereas on 64-bit Rpi OS, which is Debian based, the webengine feature is provided, on 32-bit Qt5 I find that it is missing e.g.

Code: Select all

The following packages have unmet dependencies:
 qutebrowser-qtwebengine : Depends: libqt5webenginecore5 (>= 5.7.1) but it is not installable
                           Depends: python3-pyqt5.qtwebengine (>= 5.7) but it is not installable
There are "doc" and "data" packages but no actual code for qt5 web engine:

Code: Select all

$ apt list | grep engine | grep web
libqt5webengine-data/oldstable,now 5.11.3+dfsg-2+deb10u1 all [installed]
qtwebengine5-doc-html/oldstable 5.11.3+dfsg-2+deb10u1 all
qtwebengine5-doc/oldstable,now 5.11.3+dfsg-2+deb10u1 all [installed,automatic]
qutebrowser-qtwebengine/oldstable 1.6.1-2 all
I also notice that everywhere it says "oldstable".
Is the current 32-bit Rpi OS about to be abandoned?


Regards "old stable", did you not find this post in your research prior to posting ?

viewtopic.php?f=66&t=318302
.
.

anatomy
Posts: 59
Joined: Thu Jul 22, 2021 5:42 pm

Re: Qt5 broken on Rpi OS 32-bit?

Tue Sep 21, 2021 8:33 pm

Cloudcentric wrote:
Tue Sep 21, 2021 8:25 pm
Regards "old stable", did you not find this post in your research prior to posting ?
viewtopic.php?f=66&t=318302
No, that helps thanks.

Moonmarch
Posts: 781
Joined: Thu Mar 07, 2019 1:34 am

Re: Qt5 broken on Rpi OS 32-bit?

Wed Sep 22, 2021 10:05 pm

If the software packages libqt5webenginecore5, and python3-pyqt5.qtwebengine have no installation candidate, this means the software is not in the Raspbian repository. You would have to either find a software package from a website that includes the software you are searching for or compile the software from source.

Return to “General discussion”