mjack
Posts: 11
Joined: Mon May 20, 2013 5:57 am
Location: Denmark

Re: Bullseye vncserver is very slow without display

Wed Nov 10, 2021 10:03 pm

dom wrote:
Wed Nov 10, 2021 9:54 pm
mjack wrote:
Wed Nov 10, 2021 8:11 pm
Are you saying you are not getting a 1280x720 VNC desktop?
I'm getting a 720x480 (I presume) desktop in a 1280x720 (I presume) window in VNC Viewer.

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6234
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: Bullseye vncserver is very slow without display

Wed Nov 10, 2021 10:07 pm

mjack wrote:
Wed Nov 10, 2021 10:03 pm
I'm getting a 720x480 (I presume) desktop in a 1280x720 (I presume) window in VNC Viewer.
Why do you think that? I'd assume a 1280x720 VNC viewer resolution would mean that is the resolution of the desktop the VNC server is providing.
Can you switch between lowest and highest resolutions in the display tab of Raspberry Pi Configuration and see if you get more "room" for window with the higher setting?

mjack
Posts: 11
Joined: Mon May 20, 2013 5:57 am
Location: Denmark

Re: Bullseye vncserver is very slow without display

Wed Nov 10, 2021 10:23 pm

dom wrote:
Wed Nov 10, 2021 10:07 pm
mjack wrote:
Wed Nov 10, 2021 10:03 pm
I'm getting a 720x480 (I presume) desktop in a 1280x720 (I presume) window in VNC Viewer.
Can you switch between lowest and highest resolutions in the display tab of Raspberry Pi Configuration and see if you get more "room" for window with the higher setting?
The VNC Viewer window size (and size in Sesion information) changes accordingly, after a reboot, but the actual desktop stays at 720x480.

Man in a van
Posts: 330
Joined: Sat Dec 27, 2014 2:41 pm
Location: Staffordshire, UK.

Re: Bullseye vncserver is very slow without display

Wed Nov 10, 2021 10:31 pm

mjack wrote:
Wed Nov 10, 2021 10:03 pm
dom wrote:
Wed Nov 10, 2021 9:54 pm
mjack wrote:
Wed Nov 10, 2021 8:11 pm
Are you saying you are not getting a 1280x720 VNC desktop?
I'm getting a 720x480 (I presume) desktop in a 1280x720 (I presume) window in VNC Viewer.
Same for me :?:

Image

ronnie

RonR
Posts: 2966
Joined: Tue Apr 12, 2016 10:29 pm
Location: US

Re: Bullseye vncserver is very slow without display

Wed Nov 10, 2021 10:48 pm

Man in a van wrote:
Wed Nov 10, 2021 10:31 pm
mjack wrote:
Wed Nov 10, 2021 10:03 pm
dom wrote:
Wed Nov 10, 2021 9:54 pm
I'm getting a 720x480 (I presume) desktop in a 1280x720 (I presume) window in VNC Viewer.
Same for me :?:

Image

Make sure you're updated (sudo apt update && sudo apt full-upgrade).

Then, in raspi-config (Display Options -> VNC Resolution), change to a different resolution, save it, change it back to the desired resolution, save it, and reboot.

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6234
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: Bullseye vncserver is very slow without display

Wed Nov 10, 2021 11:09 pm

The headless resolution works on Pi4.
Maybe on pi0-3 the composite resolution is overriding it.
Does:
dtoverlay=vc4-kms-v3d,nocomposite
(Replacing the existing kms line)
Help?

RonR
Posts: 2966
Joined: Tue Apr 12, 2016 10:29 pm
Location: US

Re: Bullseye vncserver is very slow without display

Wed Nov 10, 2021 11:13 pm

dom wrote:
Wed Nov 10, 2021 11:09 pm
The headless resolution works on Pi4.
Maybe on pi0-3 the composite resolution is overriding it.

I had the previously described problem two Pi4's (one Bullseye 32 and one Bullseye 64) after the latest updates. It was necessary to change to a different resolution and back followed by a reboot on both.

Man in a van
Posts: 330
Joined: Sat Dec 27, 2014 2:41 pm
Location: Staffordshire, UK.

Re: Bullseye vncserver is very slow without display

Wed Nov 10, 2021 11:16 pm

RonR wrote:
Wed Nov 10, 2021 10:48 pm
Man in a van wrote:
Wed Nov 10, 2021 10:31 pm
mjack wrote:
Wed Nov 10, 2021 10:03 pm

Same for me :?:

[

Make sure you're updated (sudo apt update && sudo apt full-upgrade).

Then, in raspi-config (Display Options -> VNC Resolution), change to a different resolution, save it, change it back to the desired resolution, save it, and reboot.
Fully updated before starting

I tried this

Raspberry Configuration in the gui, changed to the smallest resolution, rebooted.

Repeated the procedure, changed to the largest resolution, rebooted.

Screen shot shows the result.

Will try your suggestion

ronnie

@Dom

Should say, this is a piZero2W

RonR
Posts: 2966
Joined: Tue Apr 12, 2016 10:29 pm
Location: US

Re: Bullseye vncserver is very slow without display

Wed Nov 10, 2021 11:23 pm

Man in a van wrote:
Wed Nov 10, 2021 11:16 pm
Raspberry Configuration in the gui, changed to the smallest resolution, rebooted.

Repeated the procedure, changed to the largest resolution, rebooted.

Screen shot shows the result.

I believe the GUI configuration is now only for a connected monitor (not VNC). Without a connected monitor, the HDMI entries in the GUI configuration are greyed out. raspi-config must be used for VNC configuration.

Man in a van
Posts: 330
Joined: Sat Dec 27, 2014 2:41 pm
Location: Staffordshire, UK.

Re: Bullseye vncserver is very slow without display

Wed Nov 10, 2021 11:27 pm

RonR wrote:
Wed Nov 10, 2021 10:48 pm


Make sure you're updated (sudo apt update && sudo apt full-upgrade).

Then, in raspi-config (Display Options -> VNC Resolution), change to a different resolution, save it, change it back to the desired resolution, save it, and reboot.
did not work

ronnie :(

Man in a van
Posts: 330
Joined: Sat Dec 27, 2014 2:41 pm
Location: Staffordshire, UK.

Re: Bullseye vncserver is very slow without display

Wed Nov 10, 2021 11:30 pm

dom wrote:
Wed Nov 10, 2021 11:09 pm
The headless resolution works on Pi4.
Maybe on pi0-3 the composite resolution is overriding it.
Does:
dtoverlay=vc4-kms-v3d,nocomposite
(Replacing the existing kms line)
Help?
Winner! Winner! Chicken Dinner !! :o ;) :roll:

It took a few seconds for the screen to fill out, but it's there 8-)

Thanks to both; I'm off to bed for my ugly sleep :) :)

ronnie

Man in a van
Posts: 330
Joined: Sat Dec 27, 2014 2:41 pm
Location: Staffordshire, UK.

Re: Bullseye vncserver is very slow without display

Wed Nov 10, 2021 11:34 pm

RonR wrote:
Wed Nov 10, 2021 11:23 pm
Man in a van wrote:
Wed Nov 10, 2021 11:16 pm
Raspberry Configuration in the gui, changed to the smallest resolution, rebooted.

Repeated the procedure, changed to the largest resolution, rebooted.

Screen shot shows the result.

I believe the GUI configuration is now only for a connected monitor (not VNC). Without a connected monitor, the HDMI entries in the GUI configuration are greyed out. raspi-config must be used for VNC configuration.
Just to quickly add, that I choose the smallest resolution and the size of the screen did change.

ronnie

RonR
Posts: 2966
Joined: Tue Apr 12, 2016 10:29 pm
Location: US

Re: Bullseye vncserver is very slow without display

Thu Nov 11, 2021 12:00 am

dom wrote:
Wed Nov 10, 2021 11:09 pm
The headless resolution works on Pi4.
Maybe on pi0-3 the composite resolution is overriding it.
Does:
dtoverlay=vc4-kms-v3d,nocomposite
(Replacing the existing kms line)
Help?

@dom,

The addition of ',nocomposite' is required on a Raspberry Pi 3B+.

User avatar
raymate
Posts: 178
Joined: Sat Sep 28, 2013 3:56 pm
Location: Canada / UK

Re: Bullseye vncserver is very slow without display

Thu Nov 11, 2021 12:32 am

Im getting the same problem, everything is set to 720P for VNC as described by Dom (raspi-config etc)

But the virtual window it seems to be 720 x 480 inside a 720P VNC window, the desktop will not fill as asked in the preferences. See below.
Screen Shot 2021-11-10 at 19.25.59.png
Screen Shot 2021-11-10 at 19.25.59.png (191.88 KiB) Viewed 5292 times
dom wrote:
Wed Nov 10, 2021 9:54 pm
mjack wrote:
Wed Nov 10, 2021 8:11 pm
2) VNC Viewer on other machine reports 1280x720 for session.
3) Screen Configuration only has "Composite-!" screen, and 720x480 resolution.
The Screen Configuration describes physical displays.
Composite can't be auto-detected so is assume if hdmi is not connected.

If VNC viewer reports 1280x720 then what is wrong?
Are you saying you are not getting a 1280x720 VNC desktop?
___________________________________________________________________
Pi model B / Pi 2 / Pi 3 / Pi 4 / Pi 400 / Pi Zero W / Pi Zero 2 W / Pico

mjack
Posts: 11
Joined: Mon May 20, 2013 5:57 am
Location: Denmark

Re: Bullseye vncserver is very slow without display

Thu Nov 11, 2021 5:58 am

dom wrote:
Wed Nov 10, 2021 11:09 pm
Maybe on pi0-3 the composite resolution is overriding it.
Does:
dtoverlay=vc4-kms-v3d,nocomposite
(Replacing the existing kms line)
Help?
This works on a Zero 2. I can change resolution for the desktop via raspi-config and Raspberry Pi Configuration. VNV Viewer reports the resolution I select.

There's a small glitch when I log in: the Viewer window is only the size of the login dialog, and the desktop is briefly 'tiled' to fill the Viewer window. Once the desktop is settled (top bar etc), everything is fine.

Man in a van
Posts: 330
Joined: Sat Dec 27, 2014 2:41 pm
Location: Staffordshire, UK.

Re: Bullseye vncserver is very slow without display

Thu Nov 11, 2021 10:53 am

dom wrote:
Wed Nov 10, 2021 11:09 pm
The headless resolution works on Pi4.

Just a note to confirm this is so ;)

ronnie

mmozzano
Posts: 1
Joined: Sat Sep 22, 2018 7:51 pm

Re: Bullseye vncserver is very slow without display

Thu Nov 11, 2021 11:00 am

I updated from buster to bullseye on two seperate Pi4 machines last night and also having issues with vnc (getting 'Cannot currently show the desktop). When I run raspi-config however I dont see anything relating to vnc resolutions under Display Options.

I'm fully up to date when I run apt update and apt full-upgrade but when I check the version of raspi-config it comes back as...

raspi-config is already the newest version (20210212).

Am I doing something wrong?!

Update: a fresh install rather than attempting to upgrade from buster has resolved this issue.

User avatar
FTrevorGowen
Forum Moderator
Forum Moderator
Posts: 7030
Joined: Mon Mar 04, 2013 6:12 pm
Location: Bristol, U.K.

Re: Bullseye vncserver is very slow without display

Thu Nov 11, 2021 3:18 pm

FTrevorGowen wrote:
Wed Nov 10, 2021 4:01 pm
dom wrote:
Wed Nov 10, 2021 3:52 pm
There should be some updates propagating (to raspberrypi-ui-mods, raspi-config, rc-gui) that improve VNC server behaviour:

If VNC is enabled, it should now switch back to openbox rather than mutter on the next reboot. This should make the lag a lot better.

If no monitor is connected, then the new Headless Resolution combo box on the Display tab of Raspberry Pi Configuration and the corresponding VNC Resolution item in the Display menu of raspi-config can be used to set the size of the virtual desktop.

If a monitor is connected, the virtual desktop will be the same size as the connected monitor; this overrides any setting made above.

So manual changes to startlxde-pi or video= line in cmdline.txt shouldn't be needed after this.
W.r.t. "the new Headless Resolution combo box..." I'm guessing that method should now be used rather than via the vncserver's -geometry option. (Although it would be "nice", from the point of view of a vncserver launch via a PuTTY (SSH) or serial terminal session if it were possible for said geometry option to "invoke" the same function/method as the "HeadlessRes. Combo box" unless, of course it (now) does? )
Trev.
[Update]
I've now been able to update/upgrade Bullseye on a P4B and re-test VNC with and without a monitor connected. However, to perform a direct display vs. virtual with the same resolution/size I had to re-configure the monitor's setting to match one available within the "HeadlessRes. Combo box" as shown in the (VNC window) screenshots below:
With monitor (Hanns-G HL198)
VNC_Bull_Mon#1.jpg
VNC_Bull_Mon#1.jpg (130.84 KiB) Viewed 5125 times
Re-booted w/o monitor attached (ie. no uHDMI-to-HDMI cable plugged in)
VNC_Bull_NoMon#2.jpg
VNC_Bull_NoMon#2.jpg (124.58 KiB) Viewed 5125 times
Trev
Still running Raspbian Jessie or Stretch on some older Pi's (an A, B1, 2xB2, B+, P2B, 3xP0, P0W, 2xP3A+, P3B, B+, and a A+) but Buster on the P3B+, P4B's & P400. See: https://www.cpmspectrepi.uk/raspberry_pi/raspiidx.htm

Butchijo
Posts: 13
Joined: Sat Aug 29, 2015 9:54 am

Re: Bullseye vncserver is very slow without display

Thu Nov 11, 2021 6:14 pm

Just my findings.
Installed Bullseye on a PiZ2 and had problems with the VNC resolution. I tried the Suggestions above: full update and select low resolution ollowed with high resolution. The VNC size changed but the RPi window remained the same (low resolution). So the problem is not fixed on a RPiZ2.
BTW If i put the SD card out of a RPiZ2 and put it in a RPi4B then it works ok.
Last edited by Butchijo on Thu Nov 11, 2021 6:39 pm, edited 1 time in total.

User avatar
raymate
Posts: 178
Joined: Sat Sep 28, 2013 3:56 pm
Location: Canada / UK

Re: Bullseye vncserver is very slow without display

Thu Nov 11, 2021 6:20 pm

I can confirm for me on a 3B adding the "nocomposite" to the line below works I get a proper sized 720P

Code: Select all

dtoverlay=vc4-kms-v3d,nocomposite
dom wrote:
Wed Nov 10, 2021 11:09 pm
The headless resolution works on Pi4.
Maybe on pi0-3 the composite resolution is overriding it.
Does:
dtoverlay=vc4-kms-v3d,nocomposite
(Replacing the existing kms line)
Help?
___________________________________________________________________
Pi model B / Pi 2 / Pi 3 / Pi 4 / Pi 400 / Pi Zero W / Pi Zero 2 W / Pico

RobLatour
Posts: 38
Joined: Sat Dec 12, 2015 9:36 pm

Re: Bullseye vncserver is very slow without display

Thu Nov 11, 2021 6:39 pm

dom wrote: ↑
Wed Nov 10, 2021 6:09 pm
The headless resolution works on Pi4.
Maybe on pi0-3 the composite resolution is overriding it.
Does:
dtoverlay=vc4-kms-v3d,nocomposite
(Replacing the existing kms line)
Help?
( change made in /boot/config.txt )
worked for me - thanks!

peter_shaw
Posts: 16
Joined: Tue Feb 04, 2020 2:46 pm

Re: Bullseye vncserver is very slow without display

Mon Nov 15, 2021 8:18 pm

this worked for me on a fresh install. headless pi 4 using VNC

sudo nano /boot/config.txt

hdmi_force_hotplug=1
hdmi_group=2
hdmi_mode=35 #(for 1280x1024)
#dtoverlay=vc4-kms-v3d

Man in a van
Posts: 330
Joined: Sat Dec 27, 2014 2:41 pm
Location: Staffordshire, UK.

Re: Bullseye vncserver is very slow without display

Mon Nov 15, 2021 10:02 pm

please ignore original text, posted in error :oops:

ronnie

riscman
Posts: 1
Joined: Sun Sep 30, 2012 5:30 pm
Location: UK

Re: Bullseye vncserver is very slow without display

Sat Nov 20, 2021 5:31 pm

dom wrote:
Wed Nov 10, 2021 11:09 pm
The headless resolution works on Pi4.
Maybe on pi0-3 the composite resolution is overriding it.
Does:
dtoverlay=vc4-kms-v3d,nocomposite
(Replacing the existing kms line)
Help?
This works for me on a Pi3B+, but a word of warning to folks like me who don't read the instructions carefully.
Instead of replacing the existing kms line as instructed above I inserted the "dtoverlay=vc4-kms-v3d,nocomposite" after the original making the wrong assumption that the later instruction would supersede the original.
It does not work. After commenting out the original all was well. Thanks

Omniptizator
Posts: 1
Joined: Mon Dec 06, 2021 10:42 am

Re: Bullseye vncserver is very slow without display

Mon Dec 06, 2021 10:48 am

dom wrote:
Wed Nov 10, 2021 3:52 pm
There should be some updates propagating (to raspberrypi-ui-mods, raspi-config, rc-gui) that improve VNC server behaviour:

If VNC is enabled, it should now switch back to openbox rather than mutter on the next reboot. This should make the lag a lot better.

If no monitor is connected, then the new Headless Resolution combo box on the Display tab of Raspberry Pi Configuration and the corresponding VNC Resolution item in the Display menu of raspi-config can be used to set the size of the virtual desktop.

If a monitor is connected, the virtual desktop will be the same size as the connected monitor; this overrides any setting made above.

So manual changes to startlxde-pi or video= line in cmdline.txt shouldn't be needed after this.
Hi, I would like to return to initial topic of this thread - does this switch to openbox in headless imply improved overall performance for VNC? Because without the trick with "D" by @aBUGSworstnightmare in resolution in cmdline.txt I still get huge lags in Chromium (terminal window via VNC is working fine, for example).

Return to “Troubleshooting”