Posts: 44
Joined: Thu Nov 21, 2019 4:04 am
Location: Los Angeles

VLC Media Player fix!

Wed Nov 16, 2022 8:45 pm

On some of my systems I install RPI Desktop for PC/MAC to, when I fire up VLC Media Player, a large horizontal bar covers much of the screen and is impossible to get rid of - there are no handles available to close that unreadable popup. But there is an easy fix. It reads like a lot, but once you do it, it's very simple.

Being unusable, I have to go into a terminal, and use xkill to terminate it. And that kills not only the huge popup, but vlc too.

What that large horizontal bar is, is a popup window that VLC throws up the very first time, which asks you if you want to allow for metadata access to get song titles and so forth.

I think it's a combination of my screen resolution (1920x1080) and perhaps graphics card(s) that makes that first popup window unreadable and entirely too huge to close, and is persistent that you answer it if you fire up vlc again.

The quick fix for a first-time setup seems to be to go into:
Preferences > Appearance Settings > Defaults
And then choose a small or medium screen - even if you are going to use the large screen default later. Answer that first-time popup.

Fire up VLC, and everything is fine. If you are using the large screen as the default in your appearance settings, go back to that. With that very first popup window from VLC satisfied, everything is fine from now on.

Personal Installation Notes:
Normally I don't even go into "Default" settings for the screens when first installing RPI Desktop PC/MAC, and instead maybe change my font settings in the "System" area, and perhaps manually adjust things in the taskbar, by right clicking on it, and changing panel settings there to my liking.

BUT - now I am changing my initial setup routine a little bit. After a first install, I will immediately go into Appearance Settings > Default and choose a small or medium screen FIRST, fire up VLC, answer it's own popup, and then return to Large (which is what I prefer). THEN, I will fine tune font settings and so forth in the System and Taskbar to my liking.

I still like VLC. This was the easy fix for me to get around that first popup it throws. Maybe for you too if you run into the same issue.

Posts: 44
Joined: Thu Nov 21, 2019 4:04 am
Location: Los Angeles

Re: VLC Media Player fix!

Wed Nov 16, 2022 9:24 pm

DRAT! This solution isn't repeatable. It's back, although this time the top level menu's have gone away on another machine.

Gonna' work on it for a *repeatable* solution amongst several boxes. Um, nothing to see here except someone putting foot in mouth. :)

Posts: 44
Joined: Thu Nov 21, 2019 4:04 am
Location: Los Angeles

Re: VLC Media Player fix!

Thu Nov 17, 2022 12:37 am

Repeatable behaviour found - getting closer! Might be tied to fonts.

On my machines and screens ..

If one chooses the defaults for Medium-Screens in the Appearance>Defaults menu, and makes no further adjustments to the system fonts, then VLC works as expected.

Removing and reinstalling vlc is no quick-cure - the same behaviour occurs - so you can forget that. Even though that is repeatable. :)

So ... if I want to do a VLC-session, the custom lxde makes that fast and easy to do by just setting up for medium screens, and not touching anything else. When I'm done, it is just as easy to go back to my preferred large screens and system fonts.

However, the system-font of PibotoLT is drop dead gorgeous, and on my system isn't seen as pretty as it should be in VLC. So, instead of trying to convince vlc to use a different font (seems to be locked to PibotoLT 12), for my grandpa like eyes, I can scale it instead.

I can start vlc from the medium-screen default, but scale (choose what you like, ie 2 etc) with this from the command line:

Code: Select all

export QT_SCALE_FACTOR=1.5
Hmm... so I'll continue to dig. Perhaps I can force VLC to ignore system-font setting changes, and when using either Small, Medium, or Large screens in the Appearance setup, it will just scale a little bit instead.


Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6429
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: VLC Media Player fix!

Thu Nov 17, 2022 11:27 am

Can you run:
edid-decode /sys/devices/platform/gpu/drm/card0/card0-HDMI-A-1/edid
(if that file isn't present, try with card1)

and check lines like:
Maximum image size: 52 cm x 32 cm
DTD 1: 1920x1200 59.950 Hz 8:5 74.038 kHz 154.000 MHz (518 mm x 324 mm)

(basically anything with sizes in cm or mm), and check they seem vaguely plausible.

I believe Qt gets upset if the edid describes the monitor size as implausibly small.

Return to “Raspberry Pi Desktop for PC and Mac”