Posts: 1
Joined: Fri May 26, 2023 8:37 am

dtoverlay wont load 2 modules same time

Fri May 26, 2023 8:52 am

hi im trying to get my camera and display working together

this is what im trying


comes up cant load overlay ads7846 but the screen works with touch but the camera don't

so i tried other way around


now i get can't load vc4.kms.-v3d but screen works fine but camera don't I get DRI2: failed to authenticate

ive also tried

this only loads the vc4-kms-v3d and only camera works.

When i installed octopi image and put this line in dtoverlay="ads7846,cs=1,penirq=25,penirq_pull=2,speed=50000,keep_vref=0,swapxy=0,pmax=255,xohms=150,xmin=200,xmax=3900,ymin=200,ymax=3900","vc4-kms-v3d" both camera and screen touch works fine.

why does this work on octopi but not on Pi OS 64bit?

whats different?

please help, loosing will to live lol

Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 15289
Joined: Wed Dec 04, 2013 11:27 am
Location: ZZ9 Plural Z Alpha, aka just outside Cambridge.

Re: dtoverlay wont load 2 modules same time

Fri May 26, 2023 6:26 pm

If you're talking of adding entries to /boot/config.txt, then quotes are not needed, and it does not take multiple overlays.

ads7846 is an SPI touch controller, and vc4-kms-v3d is the display driver. Where does a camera come into this? And what display is the ads7846 acting as a touch controller for?
Software Engineer at Raspberry Pi Ltd. Views expressed are still personal views.
I'm not interested in doing contracts for bespoke functionality - please don't ask.

Return to “Device Tree”