Posts: 1
Joined: Wed May 29, 2013 1:29 pm

ExFat disk wont mount

Thu May 30, 2013 6:09 pm

Hi Guys, here's to my first attempts with a pi... I tried to mount my externally powerd 2TB WD hdd, but the raspberry won't let me do that. it gives an error every time that says:

Error mounting: mount: unknown filesystem type 'exfat'

I tried several googlesearches for exfat support, but none of them seem to work.

Did anyone of you expierence this? And were you able to fix the issue?


Posts: 220
Joined: Tue Oct 09, 2012 8:13 pm

Re: ExFat disk wont mount

Thu May 30, 2013 6:56 pm

exFat is a Microsoft file system, for which they don't release the specification and hold a number of Patents (pending). It is not supported by the Linux Kernel, although there seems to be a work round (see Wikipedia - exfat) but I know very little about it. You could try adding new partitions on the HDD and formatting those with a more friendly file system that does work across different operating systems. exFat seems to be designed for low capacity flash drives

Posts: 1
Joined: Sun Apr 24, 2016 6:48 am

Re: ExFat disk wont mount

Sun Apr 24, 2016 6:54 am


Please do the following to mount exFAT disk -

sudo apt-get update
sudo apt-get install exfat-fuse exfat-utils
sudo mkdir /media/exfat
sudo mount -t auto /dev/sda1 /media/USBHDD1

In the above command sda1 is the name of the exFAT disk. You can checkout the names of various disks attached to your system by running sudo fdisk -l
Now your exFAT disk will be available at /media

User avatar
Posts: 24
Joined: Wed Feb 15, 2012 7:17 pm
Location: Toronto, Canada

Re: ExFat disk wont mount

Sat Jun 06, 2020 10:10 pm

You were right.
exFAT was proprietary until 28 August 2019, when Microsoft published its specification.

Now easily solvable by loading the utils for this FS:

Code: Select all

sudo apt install exfat-fuse exfat-utils
Now mount as normal. Good luck!


Return to “Troubleshooting”