Posts: 7
Joined: Mon May 27, 2013 2:01 pm

RT5572 Driver

Thu Aug 29, 2013 10:49 am

I have got a new wifi usb stick that is based on the rt5572 chipset. although right now its useless because im having trouble finding and installing the drivers for it. If anyone could help that would be greatt

Posts: 366
Joined: Tue Aug 20, 2013 9:11 pm

Re: RT5572 Driver

Thu Aug 29, 2013 12:00 pm

Did you not check here before purchasing ?


The RT5572 is not listed above but a Linux x86 driver is available, maybe you could create a driver for the ARMv6 architecture for other users who may have the same issue:

http://www.mediatek.com/_en/07_download ... php?sn=501

Previous postings which mention the RT5572

http://www.raspberrypi.org/phpBB3/viewt ... lit=rt5572

http://www.raspberrypi.org/phpBB3/viewt ... lit=rt5572
Searching is easy, most questions have been asked before !

Posts: 54
Joined: Sun Jun 03, 2012 6:50 am

Re: RT5572 Driver

Thu Aug 29, 2013 8:13 pm

Could you post what /dmesg does?
I might be useful if there is an Invalid ****/**** in there somewhere (**** is numbers).

I recently fixed mine. The fix that I used is generic and works for, I think, all RT dongles.

Posts: 7
Joined: Mon May 27, 2013 2:01 pm

Re: RT5572 Driver

Tue Sep 03, 2013 9:20 am

Heres a dmesg output:

usb 1-1.2.1: USB disconnect, device number 5
usb 1-1.2.1: new high-speed USB device number 7 using dwc_otg
usb 1-1.2.1: New USB device found, idVendor=148f, idProduct=5572
usb 1-1.2.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 1-1.2.1: Product: 802.11 n WLAN
usb 1-1.2.1: Manufacturer: Ralink
usb 1-1.2.1: SerialNumber 1.0

Posts: 3
Joined: Mon Mar 25, 2013 7:53 pm

Re: RT5572 Driver

Sat Nov 02, 2013 11:17 pm

I have a RT5572-based USB adaptor (a TeckNet dual-band one from Amazon) working now on my Raspberry Pi. Getting it going involved a lot of tries including building a kernel from scratch, but this might not be necessary if you know how to build a device driver against an pre-existing kernel.

From what I can glean from my typing history, this is what I did:

1. change the WPA supplicant and other things in the Ralink driver sources as per http://www.ctheroux.com/2012/09/ralink- ... untu-12-04. Not everything needs to be changed now, some things are already present in the downloadable drivers.
2. get the latest RP kernel sources using “git clone --depth 1 https://github.com/raspberrypi/linux.git
3. get the tools using “git clone https://github.com/raspberrypi/tools.git
4. build the kernel using the config from “zcat /proc/config.gz” (I cross-compiled it on a PC as 20 minutes waiting is better than 6 hours)
5. install the kernel.img and modules and reboot using them
6. clean the tree you just built the kernel from
7. create a folder called “build” in the modules folder you just created, e.g. 3.6.11+
8. copy the cleaned source tree to that folder
9. build the RT5572 drivers, they will find the necessary kernel sources. The build takes many minutes on an RP
10. sudo modprobe rt5572sta
11. ifup ra0 (add this to /etc/rc.local)

Then finally:

pi@raspberrypi ~ $ ifconfig -a
eth0 Link encap:Ethernet HWaddr xx:xx:xx:xx:xx:xx
RX packets:481 errors:0 dropped:1 overruns:0 frame:0
TX packets:418 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:51348 (50.1 KiB) TX bytes:79502 (77.6 KiB)

lo Link encap:Local Loopback
inet addr: Mask:
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

ra0 Link encap:Ethernet HWaddr xx:xx:xx:xx:xx:xx
inet addr: Bcast: Mask:
RX packets:73904 errors:0 dropped:86 overruns:3 frame:3
TX packets:925 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:71629732 (68.3 MiB) TX bytes:115491 (112.7 KiB)

pi@raspberrypi ~ $ # none of this would be here without the RT5572 working, as there is no other network connection

Posts: 1
Joined: Fri Jan 17, 2014 10:43 pm

Re: RT5572 Driver

Thu Mar 20, 2014 12:06 am

Hello All,

Worked for 2.4Ghz but on 5Ghz they don´t receive IP and if I put static, don´t work either.

Any hints ?


Posts: 3
Joined: Mon Mar 25, 2013 7:53 pm

Re: RT5572 Driver

Thu Mar 20, 2014 10:05 pm

Even scanning for other stations doesn't work for 5GHz, I also only managed to get 2.4GHz working.

Posts: 2
Joined: Sat Dec 10, 2011 9:29 pm

Re: RT5572 Driver

Tue Jan 27, 2015 8:37 pm

Is there a chance I could have a copy of your image you are using on your SD card with the RT5572 driver already compiled in?

thank you.

Posts: 1
Joined: Sun Apr 26, 2015 1:53 pm

Re: RT5572 Driver

Fri May 01, 2015 2:41 pm

I am new to this forum so I don't know if this is a good place to post this information or not but I thought it might be useful to someone. I also am not sure how to format this post so I hope it looks OK. I have a TP-LINK TL-WDN3200 USB adapter which is based on a Ralink RT5572 or sometimes a RT5592. Mine is a RT5572 and with the latest version of Rasbian the Ralink RT2800USB driver is automatically installed but the adapter would only work on the 2.4 GHz band and would not scan or do anything to indicate it even had 5 GHz capabilities. I also use this adapter on a Windows system and I noticed that the default install of the driver selects the wrong region for the 5 GHz band (I am in the US region) and therefor would not work until set to the proper region. I researched how to change the region on the PI and found I needed to install a couple of packages, set the region for US and reboot, afterwards it now works on both bands.

Code: Select all

apt-get install firmware-linux-nonfree crda
Then change region

Code: Select all

iw reg set US
and reboot

Code: Select all

shutdown -r now
Scan for 5 GHz channels and they should be there.

Posts: 11
Joined: Wed Apr 15, 2015 11:52 pm

Re: RT5572 Driver

Thu Jun 30, 2016 9:17 pm

Thanks, stijim.
I have a Rosewill RNX-N600UBE with the RT5572 chipset. Your post worked for me perfectly with Raspbian Jessie.

Posts: 6
Joined: Sun Jan 17, 2016 2:25 pm

Re: RT5572 Driver

Mon Oct 10, 2016 9:01 pm

same for me. the "apt-get install firmware-linux-nonfree crda" made it work smooth and nice on 5 GHz. Magic!

Return to “Troubleshooting”