Posts: 173
Joined: Fri Jan 01, 2016 2:45 pm

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+

Fri Jan 28, 2022 12:57 am

DougieLawson wrote:
Fri Jan 28, 2022 12:45 am
Or for £6.00 swap your cheap crap Chinesium WiFi dongle for one that's fully supported by RaspiOS Bullseye.
https://uk.pi-supply.com/products/offic ... le-adapter
Out of stock.
EOL notice as of 2018 at https://www.raspberrypi.com/products/ra ... fi-dongle/

Posts: 4
Joined: Mon Apr 18, 2022 3:01 pm

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+

Mon Apr 18, 2022 3:16 pm

danjperron wrote:
Sun Aug 29, 2021 11:16 am
I tried doing so but it appears that my /etc/network/interfaces.d folder is completely empty
This is normal. You need to fill it yourself!

Enter this command and your text.

Code: Select all

sudo nano /etc/network/interfaces.d/wlan1

Code: Select all

auto wlan1
allow-hotplug wlan1
iface wlan1 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
If "wlan1" is already visible with the command "ifconfig" then you need to set wpa_supplicant.

Enter the essid and password in /etc/wpa_supplicant/wpa_supplicant.conf

Code: Select all

sudo nano /etc/wpa_supplicant/wpa_supplicant.conf

Code: Select all

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
; (I'm in Canada then put your country abbreviation)

        ssid="put your essid there"
        psk="put your password there"
b.t.w since you have wlan0, it should be wise to create another wpa_supplicant.conf like wpa.supplicant.wlan1.conf for your second wifi.
Just specify that one instead in your /etc/network/interfaces.d/wlan1 file,

What is wrong with wlan0 ??? Why do you need another wifi ???

Thanks for this. It helped me out, but I see a weird issue going on. I am getting 2 IP addresses from my DHCP server. I can only ssh to the raspberry pi via the second IP. I need the stop the raspberry pi from getting the second IP address on a single wlan interface.

I am using Bullseye 32-bit on raspberry pi 3b. I compiled the kernel module as per instructions in this thread. I have onboard WiFi disabled as it was causing system crashes. The USB dongle is not causing crashes.

output of uname -srm:

Code: Select all

Linux 5.15.32-v7+ armv7l
output of ifconfig:

Code: Select all

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet  netmask  broadcast
output of ip addr:

Code: Select all

3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 7c:c2:c6:17:0a:15 brd ff:ff:ff:ff:ff:ff
    inet brd scope global dynamic wlan0
       valid_lft 35334sec preferred_lft 35334sec
    inet brd scope global secondary dynamic noprefixroute wlan0
       valid_lft 35334sec preferred_lft 30834sec

What is going on with that secondary IP address? I don't want it assigned. I did try to remove /etc/network/interfaces.d/wlan0 but then I get no IP address at all. I also tried placing denyinterfaces wlan0 in /etc/dhcpcd.conf but once again no IP address at all.

Return to “Troubleshooting”