User avatar
Zironid
Posts: 5
Joined: Tue Feb 04, 2014 7:14 pm
Location: Colombia
Contact: Website

No video output using HDMI to VGA adapter

Tue Feb 04, 2014 8:43 pm

Hello.

A while ago I was trying to get running Kali Linux (1.0.6a, specific image for the pi) on my pi. After burning the img file on the sd card, I plug it into the pi and turn it on, but my screen, which use an HDMI to VGA adapter, doesn't turn on. I tried on a tv that supports HDMI and the analog output in another tv, and both work properly.

¿Why is this happening?

(I apologize if I broke any forum rule, it's my first thread :) )
A cyclop just have two moods: angry and asleep. - MTG card

User avatar
FTrevorGowen
Forum Moderator
Forum Moderator
Posts: 6566
Joined: Mon Mar 04, 2013 6:12 pm
Location: Bristol, U.K.
Contact: Website

Re: No video output using HDMI to VGA adapter

Tue Feb 04, 2014 9:40 pm

Sorry, I can't comment on "Kali Linux" settings, but, w.r.t. HDMI to VGA converters, some need to be powered externally since the Pi cannot supply much current through the HDMI port. However, just in case Kali Linux uses similar mechanisms to Raspbian, FWIW, there are some general notes on optimising video settings, including the use of an HDMI to VGA converter ,within my webpages at: http://www.cpmspectrepi.webspace.virgin ... tings.html
Trev.
Still running Raspbian Jessie or Stretch on some older Pi's (an A, B1, 2xB2, B+, P2B, 3xP0, P0W, 2xP3A+, P3B, B+, and a A+) but Buster on the P3B+, P4B's & P400. See: https://www.cpmspectrepi.uk/raspberry_pi/raspiidx.htm

User avatar
Zironid
Posts: 5
Joined: Tue Feb 04, 2014 7:14 pm
Location: Colombia
Contact: Website

Re: No video output using HDMI to VGA adapter

Wed Feb 05, 2014 12:17 am

Oh, I forget to say that the adapter works fine on Raspian, sorry :roll: . Thanks for the link, I will take a look.
A cyclop just have two moods: angry and asleep. - MTG card

kerpap
Posts: 2
Joined: Fri Feb 28, 2014 5:45 am

Re: No video output using HDMI to VGA adapter

Fri Feb 28, 2014 5:53 am

Same problem.
I tried modifying the "config.txt" file but there wasn't one.

User avatar
FTrevorGowen
Forum Moderator
Forum Moderator
Posts: 6566
Joined: Mon Mar 04, 2013 6:12 pm
Location: Bristol, U.K.
Contact: Website

Re: No video output using HDMI to VGA adapter

Fri Feb 28, 2014 8:17 am

kerpap wrote:Same problem.
I tried modifying the "config.txt" file but there wasn't one.
Do you mean "there wasn't one" in Kali Linux (the O.S. in use by the O.P.)?
Or are you using a NOOBS-based install (of, say, Raspbian)? If so, you can edit the "O.S. associated" config.txt via NOOBS' "built-in" editor from the "recovery mode" screen** (Hold/toggle the 'Shift' key during boot, possibly alternating with key '2' to get "hdmi safe mode" to obtain a display - unless you can make temporary use of an HDMI TV/monitor).
Trev.
**As shown here:
http://www.cpmspectrepi.webspace.virgin ... ting_Tools
Still running Raspbian Jessie or Stretch on some older Pi's (an A, B1, 2xB2, B+, P2B, 3xP0, P0W, 2xP3A+, P3B, B+, and a A+) but Buster on the P3B+, P4B's & P400. See: https://www.cpmspectrepi.uk/raspberry_pi/raspiidx.htm

kerpap
Posts: 2
Joined: Fri Feb 28, 2014 5:45 am

Re: No video output using HDMI to VGA adapter

Fri Feb 28, 2014 9:19 am

No, im using the Kali Linux distro for R-pi
I imaged the SD card my self using dd
http://docs.kali.org/armel-armhf/instal ... spberry-pi

I've read about changing the config.txt however it isnt on the SD card and nobody in the Kali linux forum has had this issue.

I am searching around the folders to see if there is something in its boot loader...

User avatar
FTrevorGowen
Forum Moderator
Forum Moderator
Posts: 6566
Joined: Mon Mar 04, 2013 6:12 pm
Location: Bristol, U.K.
Contact: Website

Re: No video output using HDMI to VGA adapter

Fri Feb 28, 2014 10:20 am

kerpap wrote:No, im using the Kali Linux distro for R-pi
I imaged the SD card my self using dd
http://docs.kali.org/armel-armhf/instal ... spberry-pi
I've read about changing the config.txt however it isnt on the SD card and nobody in the Kali linux forum has had this issue.
I am searching around the folders to see if there is something in its boot loader...
O.K., that means it could be either that the HDMI to VGA adapter is just not working with Kali Linux's "default" video mode(s) or it's a more generic problem with the device. What make, model etc. is it? (Post a link perhaps?) Is it externally powered? (Most work better if they are). Have you, or can you, had it, get it working with Raspbian? (IE. install Raspbian or use NOOBS to do so, on another SDHC card).
Trev.
Still running Raspbian Jessie or Stretch on some older Pi's (an A, B1, 2xB2, B+, P2B, 3xP0, P0W, 2xP3A+, P3B, B+, and a A+) but Buster on the P3B+, P4B's & P400. See: https://www.cpmspectrepi.uk/raspberry_pi/raspiidx.htm

User avatar
Burngate
Posts: 6483
Joined: Thu Sep 29, 2011 4:34 pm
Location: Berkshire UK Tralfamadore
Contact: Website

Re: No video output using HDMI to VGA adapter

Fri Feb 28, 2014 11:29 am

It all works, with Raspbian - which has config.txt
It doesn't work with Kali Linux, and there's no config.txt

When your Pi boots, before the Linux kernel is loaded and the ARM started, the GPU launches bootcode.bin et.al, and reads config.txt if it exists - so why not create it?

In fact, copy the known working config.txt from your Raspbian set-up to your Kali set-up.

Are you sure the Pi is booting? You may have to copy across other files if the hardware - memory, etc. - isn't supported by the firmware

space_cowboy
Posts: 2
Joined: Sat Oct 11, 2014 4:00 pm

Re: No video output using HDMI to VGA adapter

Sun Oct 26, 2014 7:11 pm

I was suffering the same issue - I copied the config.txt over to the Kali SD card (as per Burngate's suggestion) and it worked ok :D

NathanWatso123
Posts: 14
Joined: Tue Feb 16, 2016 3:55 pm

Re: No video output using HDMI to VGA adapter

Fri Feb 19, 2016 5:31 pm

I need a copy of the config.txt file as I can not get it as the Raspbian config.txt file is empty. I think they moved it somewhere. I am going to copy it, make a few changes and then move it into my Kali Linux SD card. I have spent 6 hours looking for a way and still no hope. Someone help me please.

User avatar
GTR2Fan
Posts: 1601
Joined: Sun Feb 23, 2014 9:20 pm
Location: South East UK

Re: No video output using HDMI to VGA adapter

Fri Feb 19, 2016 5:39 pm

NathanWatso123 wrote:I need a copy of the config.txt file as I can not get it as the Raspbian config.txt file is empty. I think they moved it somewhere.
Are you sure about that? It lives on the /boot partition.

Opening a terminal and typing...

Code: Select all

sudo cp /boot/config.txt /home/pi
...will place a copy in your home folder making it easier to get at.
Pi2B Mini-PC/Media Centre: ARM=1GHz (+3), Core=500MHz, v3d=500MHz, h264=333MHz, RAM=DDR2-1200 (+6/+4/+4+schmoo). Sandisk Ultra HC-I 32GB microSD card on '50=100' OCed slot (42MB/s read) running Raspbian/KODI16, Seagate 3.5" 1.5TB HDD mass storage.

Return to “Troubleshooting”